summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-09-19 15:15:08 +0000
committerMatti Bickel <mabi@gentoo.org>2010-09-19 15:15:08 +0000
commite72ac15b3157f91189a4e4ae26c7a43150e09168 (patch)
tree2d31095d6b50d8a8e75ba2be69b31ce8dc51526a /dev-lang
parentAdded ~arm keyword (diff)
downloadgentoo-2-e72ac15b3157f91189a4e4ae26c7a43150e09168.tar.gz
gentoo-2-e72ac15b3157f91189a4e4ae26c7a43150e09168.tar.bz2
gentoo-2-e72ac15b3157f91189a4e4ae26c7a43150e09168.zip
fix building against IBM DB2, you now can use your DB2_HOME env variable again (bug #337512, thanks reavertm for the patch)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/ChangeLog7
-rw-r--r--dev-lang/php/files/eblits/src_configure-v1.eblit6
-rw-r--r--dev-lang/php/files/eblits/src_configure-v52.eblit6
3 files changed, 14 insertions, 5 deletions
diff --git a/dev-lang/php/ChangeLog b/dev-lang/php/ChangeLog
index 679b80120c25..ea50c1d45808 100644
--- a/dev-lang/php/ChangeLog
+++ b/dev-lang/php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/php
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.417 2010/09/07 21:22:40 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.418 2010/09/19 15:15:08 mabi Exp $
+
+ 19 Sep 2010; Matti Bickel <mabi@gentoo.org>
+ files/eblits/src_configure-v1.eblit, files/eblits/src_configure-v52.eblit:
+ fix building against IBM DB2, you now can use your DB2_HOME env variable
+ again (bug #337512, thanks reavertm for the patch)
07 Sep 2010; Matti Bickel <mabi@gentoo.org> php-5.2.14.ebuild:
enable spl and reflection by default, following upstream (bug #310383)
diff --git a/dev-lang/php/files/eblits/src_configure-v1.eblit b/dev-lang/php/files/eblits/src_configure-v1.eblit
index 64f077bdb464..de33d69276e8 100644
--- a/dev-lang/php/files/eblits/src_configure-v1.eblit
+++ b/dev-lang/php/files/eblits/src_configure-v1.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_configure-v1.eblit,v 1.6 2010/08/09 13:02:23 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_configure-v1.eblit,v 1.7 2010/09/19 15:15:08 mabi Exp $
eblit-php-src_configure() {
PHP_DESTDIR="/usr/$(get_libdir)/php${PHP_MV}"
@@ -154,7 +154,9 @@ eblit-php-src_configure() {
phpconfutils_extension_with "empress-bcs" "empress-bcs" 0
fi
phpconfutils_extension_with "esoob" "esoob" 1
- phpconfutils_extension_with "ibm-db2" "db2" 1
+ # Needed to run conftest for IBM DB2
+ [[ -n ${DB2_HOME} ]] && export LD_LIBRARY_PATH="${DB2_HOME}/`get_libdir`"
+ phpconfutils_extension_with "ibm-db2" "db2" 1 "${DB2_HOME}"
phpconfutils_extension_with "sapdb" "sapdb" 1
phpconfutils_extension_with "solid" "solid" 1
fi
diff --git a/dev-lang/php/files/eblits/src_configure-v52.eblit b/dev-lang/php/files/eblits/src_configure-v52.eblit
index 21ca863d9173..73feceafca38 100644
--- a/dev-lang/php/files/eblits/src_configure-v52.eblit
+++ b/dev-lang/php/files/eblits/src_configure-v52.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_configure-v52.eblit,v 1.4 2010/08/11 22:30:23 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_configure-v52.eblit,v 1.5 2010/09/19 15:15:08 mabi Exp $
eblit-php-src_configure() {
export CFLAGS="${CFLAGS} -D_GNU_SOURCE"
@@ -149,7 +149,9 @@ eblit-php-src_configure() {
phpconfutils_extension_with "empress-bcs" "empress-bcs" 0
fi
phpconfutils_extension_with "esoob" "esoob" 1
- phpconfutils_extension_with "ibm-db2" "db2" 1
+ # Needed to run conftest for IBM DB2
+ [[ -n ${DB2_HOME} ]] && export LD_LIBRARY_PATH="${DB2_HOME}/`get_libdir`"
+ phpconfutils_extension_with "ibm-db2" "db2" 1 "${DB2_HOME}"
phpconfutils_extension_with "sapdb" "sapdb" 1
phpconfutils_extension_with "solid" "solid" 1
fi