summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-02-27 13:40:02 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-02-27 13:40:02 +0000
commitea0322153bdeef9e3c2a6ec9f3a645f2156e3170 (patch)
tree09b90a1cdd50642315918d76a4e21e290eda9746 /dev-lang
parentunmasked for x86 (diff)
downloadgentoo-2-ea0322153bdeef9e3c2a6ec9f3a645f2156e3170.tar.gz
gentoo-2-ea0322153bdeef9e3c2a6ec9f3a645f2156e3170.tar.bz2
gentoo-2-ea0322153bdeef9e3c2a6ec9f3a645f2156e3170.zip
removing pkg_setup() completely so people don't get the idea of activating it
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog6
-rw-r--r--dev-lang/python/python-2.3.3.ebuild22
2 files changed, 11 insertions, 17 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index e1e9c2e7332a..e4fb9058661d 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/python
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.84 2004/02/27 04:07:29 jstubbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.85 2004/02/27 13:40:01 liquidx Exp $
+
+ 27 Feb 2004; Alastair Tse <liquidx@gentoo.org> python-2.3.3.ebuild:
+ completely removed pkg_setup(), added note at the top of the ebuild where you
+ can't miss it.
27 Feb 2004; Jason Stubbs <jstubbs@gentoo.org> python-2.3.3.ebuild:
Removing portage version check again as it's preventing new installations.
diff --git a/dev-lang/python/python-2.3.3.ebuild b/dev-lang/python/python-2.3.3.ebuild
index e44abcd57e59..1d747351412a 100644
--- a/dev-lang/python/python-2.3.3.ebuild
+++ b/dev-lang/python/python-2.3.3.ebuild
@@ -1,6 +1,11 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.18 2004/02/27 04:07:29 jstubbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.19 2004/02/27 13:40:02 liquidx Exp $
+
+# NOTE about python-portage interactions :
+# - Do not add a pkg_setup() check for a certain version of portage
+# in dev-lang/python. It _WILL_ stop people installing from
+# Gentoo 1.4 images.
inherit flag-o-matic python
@@ -39,21 +44,6 @@ RDEPEND="${DEPEND} dev-python/python-fchksum"
PROVIDE="virtual/python"
-# this is to stop people shooting themselves in the foot. we can't
-# add portage to DEPENDS otherwise it'll create a circular dependency
-# NOTE from Koeri: I'm reinstating this check as people are upgrading python
-# without upgrading portage.
-# NOTE from jstubbs: Removing this check once again as it's preventing new
-# installations. Bug #43036
-#pkg_setup() {
-# if ! has_version ">=sys-apps/portage-2.0.49-r16"; then
-# eerror "Dependency Failed! Requires >=sys-apps/portage-2.0.49-r16"
-# eerror "Please run: emerge portage"
-# eerror "before proceeding. (NOTE: do not use -u if portage wants you to upgrade python)"
-# die "Requires >=sys-apps/portage-2.0.49-r16"
-# fi
-#}
-
src_unpack() {
unpack ${A}
cd ${S}