summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2008-07-15 06:44:01 +0000
committerKeri Harris <keri@gentoo.org>2008-07-15 06:44:01 +0000
commitfc1e3e1496fe7259ef3b649317e1efa08bc8df03 (patch)
tree1d4cc2bc600ea2fdaf873af46040d506d8a23398 /dev-lang
parentBumped wrong version, re-introduced previous bug that was fixed :( (diff)
downloadgentoo-2-fc1e3e1496fe7259ef3b649317e1efa08bc8df03.tar.gz
gentoo-2-fc1e3e1496fe7259ef3b649317e1efa08bc8df03.tar.bz2
gentoo-2-fc1e3e1496fe7259ef3b649317e1efa08bc8df03.zip
Fix config.h syntax. Closes #220847.
(Portage version: 2.1.5.5)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/yap/ChangeLog7
-rw-r--r--dev-lang/yap/files/yap-5.1.2-config.h.patch18
-rw-r--r--dev-lang/yap/yap-5.1.2.ebuild3
3 files changed, 26 insertions, 2 deletions
diff --git a/dev-lang/yap/ChangeLog b/dev-lang/yap/ChangeLog
index 9f4e56400921..bbfca8957e61 100644
--- a/dev-lang/yap/ChangeLog
+++ b/dev-lang/yap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/yap
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yap/ChangeLog,v 1.20 2008/02/16 17:34:52 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yap/ChangeLog,v 1.21 2008/07/15 06:44:01 keri Exp $
+
+ 15 Jul 2008; keri <keri@gentoo.org> +files/yap-5.1.2-config.h.patch,
+ yap-5.1.2.ebuild:
+ Fix up config.h syntax. Thanks to Xavian-Anderson Macpherson and Sven E. in
+ bug #220847.
16 Feb 2008; keri <keri@gentoo.org> yap-5.1.1.ebuild, yap-5.1.2.ebuild:
Move eautoconf to src_unpack. Closes #207442.
diff --git a/dev-lang/yap/files/yap-5.1.2-config.h.patch b/dev-lang/yap/files/yap-5.1.2-config.h.patch
new file mode 100644
index 000000000000..9e90d646f310
--- /dev/null
+++ b/dev-lang/yap/files/yap-5.1.2-config.h.patch
@@ -0,0 +1,18 @@
+diff -Naur Yapbroken/config.h.in Yap-5.1.2/config.h.in
+--- Yapbroken/config.h.in 2007-05-21 00:09:58.000000000 +0200
++++ Yap-5.1.2/config.h.in 2008-07-14 23:28:01.196917983 +0200
+@@ -123,10 +123,12 @@
+ in adtdefs.c
+ */
+ #define FFIEEE 1
+-#undef FFVAX /* manual */
++/*manual */
++#undef FFVAX
+
+ /* Define the standard type of a float argument to a function */
+-#define FAFloat double /* manual */
++/*manual */
++#define FAFloat double
+
+ /* Set the minimum and default heap, trail and stack size */
+ #undef MinTrailSpace
diff --git a/dev-lang/yap/yap-5.1.2.ebuild b/dev-lang/yap/yap-5.1.2.ebuild
index 2f71f13f156f..e07d96faffe3 100644
--- a/dev-lang/yap/yap-5.1.2.ebuild
+++ b/dev-lang/yap/yap-5.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yap/yap-5.1.2.ebuild,v 1.2 2008/02/16 17:34:52 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yap/yap-5.1.2.ebuild,v 1.3 2008/07/15 06:44:01 keri Exp $
inherit autotools eutils java-pkg-opt-2
@@ -30,6 +30,7 @@ S="${WORKDIR}"/${MY_P}
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-config.h.patch
epatch "${FILESDIR}"/${P}-configure.patch
epatch "${FILESDIR}"/${P}-multilib.patch
epatch "${FILESDIR}"/${P}-parallel-make.patch