summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-11-12 21:01:03 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-11-12 21:01:03 +0000
commit12fbb22e6277d60676541d7a740febb3453c5f7b (patch)
tree4b879be19404c6a9ba0776365a3d6ee1e4b3edf3 /dev-libs/OpenSRF
parent[bump] dev-perl/Class-XSAccessor-1.160.0 (diff)
downloadgentoo-2-12fbb22e6277d60676541d7a740febb3453c5f7b.tar.gz
gentoo-2-12fbb22e6277d60676541d7a740febb3453c5f7b.tar.bz2
gentoo-2-12fbb22e6277d60676541d7a740febb3453c5f7b.zip
Bump.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/OpenSRF')
-rw-r--r--dev-libs/OpenSRF/ChangeLog11
-rw-r--r--dev-libs/OpenSRF/OpenSRF-1.2.0.ebuild119
-rw-r--r--dev-libs/OpenSRF/files/OpenSRF-1.2.0-buildfix.patch136
3 files changed, 263 insertions, 3 deletions
diff --git a/dev-libs/OpenSRF/ChangeLog b/dev-libs/OpenSRF/ChangeLog
index 12dbc3cf112e..76eed783debe 100644
--- a/dev-libs/OpenSRF/ChangeLog
+++ b/dev-libs/OpenSRF/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/OpenSRF
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/OpenSRF/ChangeLog,v 1.8 2009/11/10 08:43:44 robbat2 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/OpenSRF/ChangeLog,v 1.9 2012/11/12 21:01:03 robbat2 Exp $
+
+*OpenSRF-1.2.0 (12 Nov 2012)
+
+ 12 Nov 2012; Robin H. Johnson <robbat2@gentoo.org> +OpenSRF-1.2.0.ebuild,
+ +files/OpenSRF-1.2.0-buildfix.patch:
+ Bump.
10 Nov 2009; Robin H. Johnson <robbat2@gentoo.org> -OpenSRF-0.9.ebuild,
-files/OpenSRF-0.9-buildfix.patch, -OpenSRF-1.0.1.ebuild,
@@ -42,4 +48,3 @@
+files/OpenSRF-0.9-buildfix.patch, +metadata.xml, +OpenSRF-0.9.ebuild:
Initial commit. Ebuild by Robin H Johnson <robbat2@gentoo.org>. Dependancy
for Evergreen ILS. Still needs more pkg_config instructions.
-
diff --git a/dev-libs/OpenSRF/OpenSRF-1.2.0.ebuild b/dev-libs/OpenSRF/OpenSRF-1.2.0.ebuild
new file mode 100644
index 000000000000..1bc0cbca763e
--- /dev/null
+++ b/dev-libs/OpenSRF/OpenSRF-1.2.0.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/OpenSRF/OpenSRF-1.2.0.ebuild,v 1.1 2012/11/12 21:01:02 robbat2 Exp $
+
+EAPI=5
+inherit eutils multilib flag-o-matic apache-module autotools perl-module
+
+DESCRIPTION="Framework for the high-level development of the Evergreen ILS software"
+HOMEPAGE="http://open-ils.org/"
+SRC_URI="http://open-ils.org/downloads/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="postgres +sqlite"
+DEPEND=">=www-servers/apache-2.2.9
+ >=dev-db/libdbi-drivers-0.8.2
+ >=dev-db/libdbi-0.8.2
+ net-im/ejabberd
+ dev-libs/libmemcache
+ dev-perl/Cache-Memcached
+ dev-perl/Class-DBI-AbstractSearch
+ sqlite? ( dev-perl/DBD-SQLite )
+ postgres? ( dev-perl/DBD-Pg )
+ virtual/perl-Digest-MD5
+ dev-perl/JSON-XS
+ dev-perl/net-server
+ dev-perl/UNIVERSAL-require
+ dev-perl/Unix-Syslog
+ dev-perl/XML-LibXML
+ "
+
+PERL_S="${S}/src/perl"
+
+APXS2_S="${S}/src/gateway/.libs/"
+APACHE2_MOD_FILE="${APXS2_S}/osrf_json_gateway.so ${APXS2_S}/osrf_http_translator.so"
+#APACHE2_MOD_CONF="42_${PN}"
+#APACHE2_MOD_DEFINE="FOO"
+#DOCFILES="docs/*.html"
+need_apache2_2
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ perl-module_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.0-buildfix.patch
+ eautoreconf
+}
+
+#src_compile() {
+# LIBXML2_CFLAGS=$(xml2-config --cflags)
+# LIBXML2_CFLAGS="${LIBXML2_CFLAGS//*-I}"
+# LIBXML2_HEADERS="${LIBXML2_CFLAGS// *}"
+# APR_HEADERS=$(apr-1-config --includedir)
+# APACHE2_HEADERS=$(apxs2 -q INCLUDEDIR)
+# sed -i \
+# -e '/^export PREFIX=/s,/.*,/usr,' \
+# -e '/^export BINDIR=/s,/.*,${PREFIX}/bin,' \
+# -e "/^export LIBDIR=/s,/.*,\${PREFIX}/$(get_libdir)," \
+# -e '/^export PERLDIR=/s,/.*,${LIBDIR}/perl5,' \
+# -e '/^export INCLUDEDIR=/s,/.*,${PREFIX}/include,' \
+# -e '/^export ETCDIR=/s,/.*,/etc,' \
+# -e '/^export SOCK=/s,/.*,/var/run/opensrf,' \
+# -e '/^export PID=/s,/.*,/var/run/opensrf,' \
+# -e '/^export LOG=/s,/.*,/var/log,' \
+# -e '/^export TMP=/s,/.*,/tmp,' \
+# -e '/^export APXS2=/s,/.*,/usr/sbin/apxs2,' \
+# -e "/^export APACHE2_HEADERS=/s,/.*,${APACHE2_HEADERS}," \
+# -e "/^export APR_HEADERS=/s,/.*,${APR_HEADERS}," \
+# -e "/^export LIBXML2_HEADERS=/s,/.*,${LIBXML2_HEADERS}," \
+# install.conf
+# emake verbose || die "Failed to build"
+#}
+src_configure() {
+ econf \
+ --with-apxs=/usr/sbin/apxs2 \
+ --sysconfdir=/etc/opensrf \
+ --localstatedir=/var \
+ || die "econf failed"
+ cd "${PERL_S}" && S="${PERL_S}" perl-module_src_configure || die "perl-module_src_configure failed"
+}
+
+src_compile() {
+ emake || die "main emake failed"
+ cd "${PERL_S}" && S="${PERL_S}" perl-module_src_compile || die "perl-module_src_compile failed"
+}
+
+src_install() {
+ einfo "Doing src_install"
+ #emake install-verbose DESTDIR="${D}" || die "Failed to install"
+ emake install DESTDIR="${D}" || die "Failed to install"
+ apache-module_src_install || die "apache-module_src_install failed"
+ cd "${PERL_S}" && S="${PERL_S}" perl-module_src_install || die "perl-module_src_install failed"
+ cd "${S}"
+
+ # Docs
+ dodoc README doc/*
+}
+
+src_test() {
+ emake check || die "emake check failed"
+ cd "${PERL_S}" && S="${PERL_S}" perl-module_src_test || die "perl-module_src_test failed"
+}
+
+pkg_config() {
+ :
+ #JABBER_SERVER=${JABBER_SERVER:=localhost}
+ #JABBER_PORT=${JABBER_PORT:=5222}
+ #PASSWORD=${PASSWORD:=osrf}
+ #einfo "Using Jabber server at ${JABBER_SERVER}:${JABBER_PORT}"
+ #einfo "Adding 'osrf' and 'router' users with password ${PASSWORD}"
+ #cd "${ROOT}"/usr/share/doc/${PF}/examples
+ #for user in osrf router ; do
+ # perl register.pl ${JABBER_SERVER} ${JABBER_PORT} ${user} ${PASSWORD} \
+ # || die "Failed to add $user user to server"
+ #done
+}
diff --git a/dev-libs/OpenSRF/files/OpenSRF-1.2.0-buildfix.patch b/dev-libs/OpenSRF/files/OpenSRF-1.2.0-buildfix.patch
new file mode 100644
index 000000000000..33963fe30436
--- /dev/null
+++ b/dev-libs/OpenSRF/files/OpenSRF-1.2.0-buildfix.patch
@@ -0,0 +1,136 @@
+diff -Nuar OpenSRF-1.2.0.orig/Makefile.am OpenSRF-1.2.0/Makefile.am
+--- OpenSRF-1.2.0.orig/Makefile.am 2008-10-27 05:07:06.000000000 +0000
++++ OpenSRF-1.2.0/Makefile.am 2012-11-12 20:53:22.079732392 +0000
+@@ -115,14 +115,14 @@
+ SUBDIRS = src
+
+ jserver:
+- make -s -C src jserver
++ $(MAKE) -s -C src jserver
+
+ jserver-install:
+- make -s -C src jserver-install
++ $(MAKE) -s -C src jserver-install
+
+ javascript-install:
+- make -s -C src javascript-install
++ $(MAKE) -s -C src javascript-install
+
+ install-data-hook:
+- cp @srcdir@/src/gateway/apachetools.h @includedir@/opensrf/apachetools.h
++ cp @srcdir@/src/gateway/apachetools.h $(DESTDIR)@includedir@/opensrf/apachetools.h
+
+diff -Nuar OpenSRF-1.2.0.orig/src/gateway/Makefile.am OpenSRF-1.2.0/src/gateway/Makefile.am
+--- OpenSRF-1.2.0.orig/src/gateway/Makefile.am 2008-08-18 19:14:00.000000000 +0000
++++ OpenSRF-1.2.0/src/gateway/Makefile.am 2012-11-12 20:53:22.079732392 +0000
+@@ -16,16 +16,25 @@
+
+ AM_CFLAGS = -D_LARGEFILE64_SOURCE -Wall -I@abs_top_srcdir@/include/ -I$(LIBXML2_HEADERS) -I$(APACHE2_HEADERS) -I$(APR_HEADERS)
+ AM_LDFLAGS = -L$(LIBDIR) -L@top_builddir@/src/libopensrf
++APACHE_DEPS = apachetools.c apachetools.h
++LIBS=libopensrf.so
++TARGETS = osrf_json_gateway.la osrf_http_translator.la
+
+-install-exec-local:
+- if [ ! "$$(grep mod_placeholder `apxs2 -q SYSCONFDIR`/httpd.conf)" ]; \
+- then echo -e "#\n#LoadModule mod_placeholder /usr/lib/apache2/modules/mod_placeholder.so" \
+- >> `apxs2 -q SYSCONFDIR`/httpd.conf; \
+- fi
+- $(APXS2) -c $(DEF_LDLIBS) $(AM_CFLAGS) $(AM_LDFLAGS) @srcdir@/osrf_json_gateway.c apachetools.c apachetools.h libopensrf.so
+- $(APXS2) -c $(DEF_LDLIBS) $(AM_CFLAGS) $(AM_LDFLAGS) @srcdir@/osrf_http_translator.c apachetools.c apachetools.h libopensrf.so
+- $(APXS2) -i -a @srcdir@/osrf_json_gateway.la
+- $(APXS2) -i -a @srcdir@/osrf_http_translator.la
++all: $(TARGETS)
++
++osrf_json_gateway.la: osrf_json_gateway.c $(APACHE_DEPS)
++ $(APXS2) -c $(DEF_LDLIBS) $(AM_CFLAGS) $(AM_LDFLAGS) $^ $(LIBS)
++
++osrf_http_translator.la: osrf_http_translator.c $(APACHE_DEPS)
++ $(APXS2) -c $(DEF_LDLIBS) $(AM_CFLAGS) $(AM_LDFLAGS) $^ $(LIBS)
++
++#install-exec-local: $(TARGETS)
++# if [ ! "$$(grep mod_placeholder `apxs2 -q SYSCONFDIR`/httpd.conf)" ]; \
++# then echo -e "#\n#LoadModule mod_placeholder /usr/lib/apache2/modules/mod_placeholder.so" \
++# >> `apxs2 -q SYSCONFDIR`/httpd.conf; \
++# fi
++# $(APXS2) -i -a osrf_json_gateway.la
++# $(APXS2) -i -a osrf_http_translator.la
+
+ clean-local:
+ rm -f @srcdir@/osrf_http_translator.la @srcdir@/osrf_http_translator.lo @srcdir@/osrf_http_translator.slo @srcdir@/osrf_json_gateway.la @srcdir@/osrf_json_gateway.lo @srcdir@/osrf_json_gateway.slo
+diff -Nuar OpenSRF-1.2.0.orig/src/java/Makefile.am OpenSRF-1.2.0/src/java/Makefile.am
+--- OpenSRF-1.2.0.orig/src/java/Makefile.am 2008-07-17 18:15:09.000000000 +0000
++++ OpenSRF-1.2.0/src/java/Makefile.am 2012-11-12 20:53:22.079732392 +0000
+@@ -48,8 +48,8 @@
+ rm files;
+
+ install-data-local:
+- mkdir -p $(LIBDIR)/java
+- cp opensrf.jar $(LIBDIR)/java
++ mkdir -p $(DESTDIR)$(LIBDIR)/java
++ cp opensrf.jar $(DESTDIR)$(LIBDIR)/java
+
+ dep_clean:
+ rm -rf deps
+diff -Nuar OpenSRF-1.2.0.orig/src/libopensrf/Makefile.am OpenSRF-1.2.0/src/libopensrf/Makefile.am
+--- OpenSRF-1.2.0.orig/src/libopensrf/Makefile.am 2009-04-08 02:48:02.000000000 +0000
++++ OpenSRF-1.2.0/src/libopensrf/Makefile.am 2012-11-12 20:53:22.079732392 +0000
+@@ -99,6 +99,7 @@
+ opensrf_c_SOURCES = opensrf.c
+ opensrf_c_DEPENDENCIES = libopensrf.la
+
++osrf_json_test_DEPENDENCIES = libopensrf.la libosrf_json.la
+ osrf_json_test_SOURCES = osrf_json_test.c $(JSON_TARGS) $(JSON_DEP) $(JSON_TARGS_HEADS) $(JSON_DEP_HEADS)
+
+ noinst_LTLIBRARIES = libosrf_json.la
+diff -Nuar OpenSRF-1.2.0.orig/src/Makefile.am OpenSRF-1.2.0/src/Makefile.am
+--- OpenSRF-1.2.0.orig/src/Makefile.am 2009-05-31 19:49:00.000000000 +0000
++++ OpenSRF-1.2.0/src/Makefile.am 2012-11-12 20:53:52.475676800 +0000
+@@ -17,7 +17,7 @@
+ export OPENSRF = opensrf
+ export BINDIR = @bindir@
+ export LIBDIR = @libdir@
+-jsdir = $(LIBDIR)/javascript
++jsdir = $(datarootdir)/opensrf/javascript
+ export OSRF_JAVA_DEPSDIR = @OSRF_JAVA_DEPSDIR@
+ etcdir = $(ETCDIR)
+
+@@ -33,7 +33,7 @@
+ MAYBE_JA = java
+ endif
+
+-SUBDIRS = libopensrf c-apps router srfsh jserver gateway perl $(MAYBE_PY) $(MAYBE_JA)
++SUBDIRS = libopensrf c-apps router srfsh jserver gateway $(MAYBE_PY) $(MAYBE_JA) # perl is now seperate
+
+ dist_bin_SCRIPTS = @top_srcdir@/bin/opensrf-perl.pl
+ bin_SCRIPTS = @top_srcdir@/bin/osrf_config @top_srcdir@/bin/osrf_ctl.sh
+@@ -41,11 +41,11 @@
+ dist_sysconf_DATA = @top_srcdir@/examples/opensrf.xml.example @top_srcdir@/examples/opensrf_core.xml.example @top_srcdir@/examples/srfsh.xml.example
+
+ install-exec-local:
+- mkdir -p $(VAR)
+- mkdir -p $(PID)
+- mkdir -p $(LOG)
+- mkdir -p $(SOCK)
+- mkdir -p $(jsdir)
++ mkdir -p $(DESTDIR)$(VAR)
++ mkdir -p $(DESTDIR)$(PID)
++ mkdir -p $(DESTDIR)$(LOG)
++ mkdir -p $(DESTDIR)$(SOCK)
++ mkdir -p $(DESTDIR)$(jsdir)
+
+ install-exec-hook:
+ sed -i 's|LOCALSTATEDIR|$(VAR)|g' '$(DESTDIR)@sysconfdir@/opensrf.xml.example'
+@@ -54,9 +54,9 @@
+ sed -i 's|SYSCONFDIR|$(ETCDIR)|g' '$(DESTDIR)@sysconfdir@/opensrf_core.xml.example'
+ sed -i 's|LOCALSTATEDIR|$(VAR)|g' '$(DESTDIR)@sysconfdir@/srfsh.xml.example'
+ sed -i 's|SYSCONFDIR|$(ETCDIR)|g' '$(DESTDIR)@sysconfdir@/srfsh.xml.example'
+- cp -r @srcdir@/javascript/* $(jsdir)/
++ cp -r @srcdir@/javascript/* $(DESTDIR)$(jsdir)/
+
+ uninstall-hook:
+- rm @includedir@/opensrf/apachetools.h
+- rm -R $(jsdir)
++ rm $(DESTDIR)@includedir@/opensrf/apachetools.h
++ rm -R $(DESTDIR)$(jsdir)
+