summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2006-05-06 14:51:28 +0000
committerMichael Imhof <tantive@gentoo.org>2006-05-06 14:51:28 +0000
commit35e991deaec041fe8392ed6da6b1ceb1fedd8997 (patch)
tree646326f3a09eeb4c2e649a7e64c4cd23b7efdbd5 /dev-libs/ace
parentRevision bump, updating to bristuff-0.3.0-PRE-1o. (diff)
downloadgentoo-2-35e991deaec041fe8392ed6da6b1ceb1fedd8997.tar.gz
gentoo-2-35e991deaec041fe8392ed6da6b1ceb1fedd8997.tar.bz2
gentoo-2-35e991deaec041fe8392ed6da6b1ceb1fedd8997.zip
Removed old ebuilds.
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'dev-libs/ace')
-rw-r--r--dev-libs/ace/ChangeLog11
-rw-r--r--dev-libs/ace/ace-5.4.6.ebuild4
-rw-r--r--dev-libs/ace/ace-5.5.ebuild65
-rw-r--r--dev-libs/ace/files/digest-ace-5.53
4 files changed, 80 insertions, 3 deletions
diff --git a/dev-libs/ace/ChangeLog b/dev-libs/ace/ChangeLog
index e0677252974f..646aed7453bb 100644
--- a/dev-libs/ace/ChangeLog
+++ b/dev-libs/ace/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/ace
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.31 2006/02/04 02:37:03 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.32 2006/05/06 14:51:27 tantive Exp $
+
+*ace-5.5 (06 May 2006)
+
+ 06 May 2006; Michael Imhof <tantive@gentoo.org> -ace-5.4.3.ebuild,
+ ace-5.4.6.ebuild, +ace-5.5.ebuild:
+ Removed old ebuilds. Marked x86.
+
+ 04 May 2006; Michael Imhof <tantive@gentoo.org> +ace-5.5.ebuild:
+ Version bumped. Closes #131584.
04 Feb 2006; Marcelo Goes <vanquirius@gentoo.org> ace-5.4.6.ebuild:
Make modular X friendly, add missing X to IUSE.
diff --git a/dev-libs/ace/ace-5.4.6.ebuild b/dev-libs/ace/ace-5.4.6.ebuild
index 8908e0d6a601..805b0a044893 100644
--- a/dev-libs/ace/ace-5.4.6.ebuild
+++ b/dev-libs/ace/ace-5.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.4.6.ebuild,v 1.2 2006/02/04 02:37:03 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.4.6.ebuild,v 1.3 2006/05/06 14:51:27 tantive Exp $
inherit eutils
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.cs.wustl.edu/~schmidt/ACE.html"
SLOT="0"
LICENSE="BSD as-is"
-KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64"
+KEYWORDS="x86 ~sparc ~ppc ~alpha ~amd64"
IUSE="X ipv6"
DEPEND="dev-libs/openssl"
diff --git a/dev-libs/ace/ace-5.5.ebuild b/dev-libs/ace/ace-5.5.ebuild
new file mode 100644
index 000000000000..398c67e89753
--- /dev/null
+++ b/dev-libs/ace/ace-5.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.5.ebuild,v 1.1 2006/05/06 14:51:27 tantive Exp $
+
+inherit eutils
+
+S="${WORKDIR}/ACE_wrappers"
+DESCRIPTION="The Adaptive Communications Environment"
+SRC_URI="http://deuce.doc.wustl.edu/old_distribution/ACE-${PV}.tar.bz2"
+HOMEPAGE="http://www.cs.wustl.edu/~schmidt/ACE.html"
+
+SLOT="0"
+LICENSE="BSD as-is"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64"
+IUSE="X ipv6"
+
+DEPEND="dev-libs/openssl"
+
+RDEPEND="${DEPEND}
+ X? ( || (
+ ( x11-libs/libXt
+ x11-libs/libXaw )
+ virtual/x11 )
+ )"
+
+DEPEND="${DEPEND}
+ X? ( || (
+ ( x11-proto/xproto )
+ virtual/x11 )
+ )"
+
+src_compile() {
+ export ACE_ROOT="${S}"
+ mkdir build
+ cd build
+ ECONF_SOURCE="${S}"
+ econf --enable-lib-all $(use_with X) $(use_enable ipv6)
+ # --with-qos needs ACE_HAS_RAPI
+ emake static_libs=1 || die
+}
+
+
+src_test() {
+ cd ${S}/build
+ make ACE_ROOT=${S} check || die "self test failed"
+ #einfo "src_test currently stalls after Process_Mutex_Test"
+}
+
+src_install() {
+ cd build
+ make ACE_ROOT="${S}" DESTDIR="${D}" install || die "failed to install"
+}
+
+
+pkg_postinst() {
+ # This is required, as anything trying to compile against ACE will have
+ # problems with conflicting OS.h files if this is not done.
+
+ local CC_MACHINE=`gcc -dumpmachine`
+ local CC_VERSION=`gcc -dumpversion`
+ if [ -d "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace" ]; then
+ mv "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace" \
+ "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace.old"
+ fi
+}
diff --git a/dev-libs/ace/files/digest-ace-5.5 b/dev-libs/ace/files/digest-ace-5.5
new file mode 100644
index 000000000000..d7f84d5b057c
--- /dev/null
+++ b/dev-libs/ace/files/digest-ace-5.5
@@ -0,0 +1,3 @@
+MD5 23b8278b50b43ed9b6fa096a65436878 ACE-5.5.tar.bz2 7595626
+RMD160 300763ae9e46975ec35fb0cbe0d9b1959058c2dc ACE-5.5.tar.bz2 7595626
+SHA256 174f665d96edd8af2b38123e0c94039f8f429ecee99d9cb761afde1a082f5ddd ACE-5.5.tar.bz2 7595626