summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-20 09:48:32 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-09-20 09:48:32 +0000
commitb0abc126788ff0a24f9d15877fc15cfda1d23a9e (patch)
treee3a39c5e4109e65234ccd89b80430226069faf01 /dev-libs/apr-util
parentFix --as-needed issue (#284924) and quote destination directories. (diff)
downloadgentoo-2-b0abc126788ff0a24f9d15877fc15cfda1d23a9e.tar.gz
gentoo-2-b0abc126788ff0a24f9d15877fc15cfda1d23a9e.tar.bz2
gentoo-2-b0abc126788ff0a24f9d15877fc15cfda1d23a9e.zip
Fix building with sys-libs/db:4.8 (bug #285522).
(Portage version: 14288-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/apr-util')
-rw-r--r--dev-libs/apr-util/ChangeLog7
-rw-r--r--dev-libs/apr-util/apr-util-1.3.9.ebuild7
-rw-r--r--dev-libs/apr-util/files/apr-util-1.3.9-support_berkeley_db-4.8.patch129
3 files changed, 140 insertions, 3 deletions
diff --git a/dev-libs/apr-util/ChangeLog b/dev-libs/apr-util/ChangeLog
index 1a2e992f8e4f..ad9e6b976fb3 100644
--- a/dev-libs/apr-util/ChangeLog
+++ b/dev-libs/apr-util/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/apr-util
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.143 2009/09/20 08:54:12 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.144 2009/09/20 09:48:31 arfrever Exp $
+
+ 20 Sep 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ apr-util-1.3.9.ebuild,
+ +files/apr-util-1.3.9-support_berkeley_db-4.8.patch:
+ Fix building with sys-libs/db:4.8 (bug #285522).
20 Sep 2009; Benedikt Böhm <hollow@gentoo.org> -apr-util-1.3.7.ebuild,
-apr-util-1.3.8.ebuild:
diff --git a/dev-libs/apr-util/apr-util-1.3.9.ebuild b/dev-libs/apr-util/apr-util-1.3.9.ebuild
index 6bac699794b6..9d0491b28896 100644
--- a/dev-libs/apr-util/apr-util-1.3.9.ebuild
+++ b/dev-libs/apr-util/apr-util-1.3.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.3.9.ebuild,v 1.10 2009/08/24 14:54:20 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.3.9.ebuild,v 1.11 2009/09/20 09:48:31 arfrever Exp $
EAPI="2"
@@ -8,7 +8,7 @@ EAPI="2"
#APR_PV=${PV}
APR_PV="1.3.8"
-inherit db-use libtool multilib
+inherit autotools db-use eutils libtool multilib
DESCRIPTION="Apache Portable Runtime Utility Library"
HOMEPAGE="http://apr.apache.org/"
@@ -35,6 +35,9 @@ DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
src_prepare() {
+ epatch "${FILESDIR}/${P}-support_berkeley_db-4.8.patch"
+ eautoreconf
+
elibtoolize
}
diff --git a/dev-libs/apr-util/files/apr-util-1.3.9-support_berkeley_db-4.8.patch b/dev-libs/apr-util/files/apr-util-1.3.9-support_berkeley_db-4.8.patch
new file mode 100644
index 000000000000..31c4c032f32f
--- /dev/null
+++ b/dev-libs/apr-util/files/apr-util-1.3.9-support_berkeley_db-4.8.patch
@@ -0,0 +1,129 @@
+--- build/dbm.m4
++++ build/dbm.m4
+@@ -522,6 +522,25 @@
+ apu_db_version=4
+ fi
+ ])
++dnl
++dnl APU_CHECK_DB48: is DB4.8 present?
++dnl
++dnl if present: sets apu_db_header, apu_db_lib, and apu_db_version
++dnl
++AC_DEFUN([APU_CHECK_DB48], [
++ places=$1
++ if test -z "$places"; then
++ places="std /usr/local/BerkeleyDB.4.8 /boot/home/config"
++ fi
++ APU_CHECK_BERKELEY_DB("4", "8", "-1",
++ "$places",
++ "db48/db.h db4/db.h db.h",
++ "db-4.8 db4-4.8 db48 db4 db"
++ )
++ if test "$apu_have_db" = "1"; then
++ apu_db_version=4
++ fi
++])
+
+ AC_DEFUN([APU_CHECK_DB], [
+ requested=$1
+@@ -606,6 +625,12 @@
+ AC_MSG_ERROR(Berkeley db4 not found)
+ fi
+ ;;
++ db48)
++ APU_CHECK_DB48("$check_places")
++ if test "$apu_db_version" != "4"; then
++ AC_MSG_ERROR(Berkeley db4 not found)
++ fi
++ ;;
+ default)
+ APU_CHECK_DB_ALL("$check_places")
+ ;;
+@@ -613,34 +638,37 @@
+ ])
+
+ dnl
+-dnl APU_CHECK_DB_ALL: Try all Berkeley DB versions, from 4.7 to 1.
++dnl APU_CHECK_DB_ALL: Try all Berkeley DB versions, from 4.8 to 1.
+ dnl
+ AC_DEFUN([APU_CHECK_DB_ALL], [
+ all_places=$1
+
+- APU_CHECK_DB47("$all_places")
++ APU_CHECK_DB48("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB46("$all_places")
++ APU_CHECK_DB47("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB45("$all_places")
++ APU_CHECK_DB46("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB44("$all_places")
++ APU_CHECK_DB45("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB43("$all_places")
++ APU_CHECK_DB44("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB42("$all_places")
++ APU_CHECK_DB43("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB41("$all_places")
++ APU_CHECK_DB42("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB4("$all_places")
++ APU_CHECK_DB41("$all_places")
+ if test "$apu_db_version" != "4"; then
+- APU_CHECK_DB3("$all_places")
+- if test "$apu_db_version" != "3"; then
+- APU_CHECK_DB2("$all_places")
+- if test "$apu_db_version" != "2"; then
+- APU_CHECK_DB1("$all_places")
+- if test "$apu_db_version" != "1"; then
+- APU_CHECK_DB185("$all_places")
++ APU_CHECK_DB4("$all_places")
++ if test "$apu_db_version" != "4"; then
++ APU_CHECK_DB3("$all_places")
++ if test "$apu_db_version" != "3"; then
++ APU_CHECK_DB2("$all_places")
++ if test "$apu_db_version" != "2"; then
++ APU_CHECK_DB1("$all_places")
++ if test "$apu_db_version" != "1"; then
++ APU_CHECK_DB185("$all_places")
++ fi
+ fi
+ fi
+ fi
+@@ -679,11 +707,11 @@
+ apu_db_version=0
+
+ AC_ARG_WITH(dbm, [APR_HELP_STRING([--with-dbm=DBM], [choose the DBM type to use.
+- DBM={sdbm,gdbm,ndbm,db,db1,db185,db2,db3,db4,db41,db42,db43,db44,db45,db46,db47}])],
++ DBM={sdbm,gdbm,ndbm,db,db1,db185,db2,db3,db4,db41,db42,db43,db44,db45,db46,db47,db48}])],
+ [
+ if test "$withval" = "yes"; then
+ AC_MSG_ERROR([--with-dbm needs to specify a DBM type to use.
+- One of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47])
++ One of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47, db48])
+ fi
+ requested="$withval"
+ ], [
+@@ -882,6 +910,10 @@
+ apu_use_db=1
+ apu_default_dbm=db4
+ ;;
++ db48)
++ apu_use_db=1
++ apu_default_dbm=db4
++ ;;
+ default)
+ dnl ### use more sophisticated DBMs for the default?
+ apu_default_dbm="sdbm (default)"
+@@ -889,7 +921,7 @@
+ ;;
+ *)
+ AC_MSG_ERROR([--with-dbm=$look_for is an unknown DBM type.
+- Use one of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47])
++ Use one of: sdbm, gdbm, ndbm, db, db1, db185, db2, db3, db4, db41, db42, db43, db44, db45, db46, db47, db48])
+ ;;
+ esac
+