summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-25 18:28:14 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-25 18:28:14 +0000
commit13fd95dba50ef35b8570dec32c5f1eda545fd53e (patch)
treeac8090d32a8e28d922d3ae627c43424aa6789bfc /dev-libs/boost/boost-1.39.0.ebuild
parentDelete older ebuild. (diff)
downloadgentoo-2-13fd95dba50ef35b8570dec32c5f1eda545fd53e.tar.gz
gentoo-2-13fd95dba50ef35b8570dec32c5f1eda545fd53e.tar.bz2
gentoo-2-13fd95dba50ef35b8570dec32c5f1eda545fd53e.zip
Delete calls to deprecated python_version().
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/boost/boost-1.39.0.ebuild')
-rw-r--r--dev-libs/boost/boost-1.39.0.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/dev-libs/boost/boost-1.39.0.ebuild b/dev-libs/boost/boost-1.39.0.ebuild
index 27733ce2b64a..c07ea6483aad 100644
--- a/dev-libs/boost/boost-1.39.0.ebuild
+++ b/dev-libs/boost/boost-1.39.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.39.0.ebuild,v 1.8 2009/11/25 17:59:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.39.0.ebuild,v 1.9 2010/04/25 18:28:14 arfrever Exp $
EAPI="2"
@@ -117,8 +117,7 @@ src_configure() {
use mpi && mpi="using mpi ;"
if use python ; then
- python_version
- pystring="using python : ${PYVER} : /usr : /usr/include/python${PYVER} : /usr/lib/python${PYVER} ;"
+ pystring="using python : $(python_get_version) : /usr : $(python_get_includedir) : $(python_get_libdir) ;"
fi
cat > "${S}/user-config.jam" << __EOF__
@@ -221,10 +220,10 @@ src_install () {
# Move the mpi.so to the right place and make sure it's slotted
if use mpi && use python; then
- mkdir -p "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}"
- mv "${D}/usr/$(get_libdir)/mpi.so" "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/"
- touch "${D}/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/__init__.py"
- _add_line "python=\"/usr/$(get_libdir)/python${PYVER}/site-packages/boost_${MAJOR_PV}/mpi.so\""
+ mkdir -p "${D}$(python_get_sitedir)/boost_${MAJOR_PV}"
+ mv "${D}/usr/$(get_libdir)/mpi.so" "${D}$(python_get_sitedir)/boost_${MAJOR_PV}/"
+ touch "${D}$(python_get_sitedir)/boost_${MAJOR_PV}/__init__.py"
+ _add_line "python=\"$(python_get_sitedir)/boost_${MAJOR_PV}/mpi.so\""
fi
if use doc ; then