summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2006-10-22 13:49:00 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2006-10-22 13:49:00 +0000
commitf2cc162d318351f7dc0da77b70584c24b203582c (patch)
tree1b3ddc9dcb0b038b3d3aee9e2b1408debfdf62c2 /dev-libs/cryptlib
parentLot of bugfixes (diff)
downloadgentoo-2-f2cc162d318351f7dc0da77b70584c24b203582c.tar.gz
gentoo-2-f2cc162d318351f7dc0da77b70584c24b203582c.tar.bz2
gentoo-2-f2cc162d318351f7dc0da77b70584c24b203582c.zip
Version bump, fixed QA issues by removing assembly parts, adds odbc use flag (Thanks to Daniel Plaza), closes bug#105954.
(Portage version: 2.1.1)
Diffstat (limited to 'dev-libs/cryptlib')
-rw-r--r--dev-libs/cryptlib/ChangeLog11
-rw-r--r--dev-libs/cryptlib/cryptlib-3.3.0.ebuild74
-rw-r--r--dev-libs/cryptlib/files/cryptlib-3.3.0-ld.patch13
-rw-r--r--dev-libs/cryptlib/files/digest-cryptlib-3.3.06
4 files changed, 102 insertions, 2 deletions
diff --git a/dev-libs/cryptlib/ChangeLog b/dev-libs/cryptlib/ChangeLog
index f3b30fd4a8d2..e1afd8555b59 100644
--- a/dev-libs/cryptlib/ChangeLog
+++ b/dev-libs/cryptlib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/cryptlib
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/ChangeLog,v 1.11 2005/11/02 03:38:45 sbriesen Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/ChangeLog,v 1.12 2006/10/22 13:49:00 alonbl Exp $
+
+*cryptlib-3.3.0 (22 Oct 2006)
+
+ 22 Oct 2006; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/cryptlib-3.3.0-ld.patch, +cryptlib-3.3.0.ebuild:
+ Version bump, fixed QA issues by removing assembly parts, adds odbc use flag
+ (Thanks to Daniel Plaza), closes bug#105954.
*cryptlib-3.2.2 (02 Nov 2005)
diff --git a/dev-libs/cryptlib/cryptlib-3.3.0.ebuild b/dev-libs/cryptlib/cryptlib-3.3.0.ebuild
new file mode 100644
index 000000000000..b0f904834aa6
--- /dev/null
+++ b/dev-libs/cryptlib/cryptlib-3.3.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cryptlib/cryptlib-3.3.0.ebuild,v 1.1 2006/10/22 13:49:00 alonbl Exp $
+
+inherit eutils multilib flag-o-matic
+
+MY_PV="${PV//.0}"
+MY_PV="${MY_PV//.}"
+
+DESCRIPTION="Powerful security toolkit for adding encryption to software"
+HOMEPAGE="http://www.cs.auckland.ac.nz/~pgut001/cryptlib/"
+SRC_URI="ftp://ftp.franken.de/pub/crypt/cryptlib/cl${MY_PV}.zip
+ doc? ( mirror://gentoo/${P}-manual.pdf.bz2 )"
+
+LICENSE="Sleepycat"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE="doc static odbc"
+
+S="${WORKDIR}"
+
+RDEPEND="odbc? ( dev-db/unixODBC )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ app-arch/unzip"
+
+src_unpack() {
+ # we need the -a option, so we can not use 'unpack'
+ unzip -qoa "${DISTDIR}/cl${MY_PV}.zip"
+ use doc && unpack "${P}-manual.pdf.bz2"
+
+ # we want our own CFLAGS) ;-)
+ sed -i -e "s:-m.*=pentium::g" -e "s:-fomit-frame-pointer::g" -e "s:-O2::g" \
+ -e "s:-O3::g" -e "s:-O4::g" makefile || die "sed makefile failed"
+
+ # change 'make' to '$(MAKE)'
+ sed -i -e "s:@\?make:\$(MAKE):g" makefile || die "sed makefile failed"
+
+ # NOTICE:
+ # Because of stack execution
+ # assembly parts are disabled.
+ sed -i -e 's:i\[3,4,5,6\]86:___:g' makefile || die "sed makefile failed"
+
+ # fix soname and strip issues
+ epatch "${FILESDIR}/${P}-ld.patch"
+}
+
+src_compile() {
+ # we need at least -O2
+ replace-flags -O -O2
+ replace-flags -Os -O2
+ replace-flags -O1 -O2
+ local MYCFLAGS="-c -D__UNIX__ -DNDEBUG -I. ${CFLAGS}"
+
+ if use static; then
+ emake -j1 CFLAGS="${MYCFLAGS}" SCFLAGS="${MYCFLAGS} -fPIC" || \
+ die "emake static failed"
+ fi
+
+ emake -j1 shared CFLAGS="${MYCFLAGS}" SCFLAGS="${MYCFLAGS} -fPIC" || \
+ die "emake shared failed"
+}
+
+src_install() {
+ dolib.so "libcl.so.${PV}"
+ dosym "libcl.so.${PV}" "/usr/$(get_libdir)/libcl.so"
+ use static && dolib.a "libcl.a"
+
+ insinto /usr/include
+ doins cryptlib.h
+
+ dodoc README
+ use doc && newdoc "${P}-manual.pdf" "manual.pdf"
+}
diff --git a/dev-libs/cryptlib/files/cryptlib-3.3.0-ld.patch b/dev-libs/cryptlib/files/cryptlib-3.3.0-ld.patch
new file mode 100644
index 000000000000..18ed2962f5fa
--- /dev/null
+++ b/dev-libs/cryptlib/files/cryptlib-3.3.0-ld.patch
@@ -0,0 +1,13 @@
+--- ./tools/buildsharedlib.sh.old 2006-10-22 15:24:29.000000000 +0200
++++ ./tools/buildsharedlib.sh 2006-10-22 15:25:49.000000000 +0200
+@@ -98,7 +98,8 @@ case $OSNAME in
+ strip $LIBNAME ;;
+
+ *)
+- $LD -shared -o $LIBNAME `cat $LINKFILE` `./tools/getlibs.sh autodetect` ;
+- strip $LIBNAME ;;
++ $LD -shared -Wl,-soname,$LIBNAME -o $LIBNAME `cat $LINKFILE` `./tools/getlibs.sh autodetect` ;
++# strip $LIBNAME
++ ;;
+ esac
+ rm -f $LINKFILE
diff --git a/dev-libs/cryptlib/files/digest-cryptlib-3.3.0 b/dev-libs/cryptlib/files/digest-cryptlib-3.3.0
new file mode 100644
index 000000000000..93e5105518fc
--- /dev/null
+++ b/dev-libs/cryptlib/files/digest-cryptlib-3.3.0
@@ -0,0 +1,6 @@
+MD5 386abce26023fe1ca3bf67cb4b2d739f cl33.zip 3779126
+RMD160 82e38db5ceed4a1c7ae7f58510c1005b7760fa87 cl33.zip 3779126
+SHA256 8c9d784d7699456e1aff2211cde6b95962116f43a05e869a0caec21b5be754b8 cl33.zip 3779126
+MD5 ca68f04b53b4b7817c789f9021d57110 cryptlib-3.3.0-manual.pdf.bz2 1682939
+RMD160 3a49a5e4fdb7cf6d9dff39484657ac79330a7351 cryptlib-3.3.0-manual.pdf.bz2 1682939
+SHA256 1cf398964cad66b729d278b133ef463075b7824914e082b0fe0b086810a6b0e1 cryptlib-3.3.0-manual.pdf.bz2 1682939