summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2005-08-17 00:38:55 +0000
committerRyan Phillips <rphillips@gentoo.org>2005-08-17 00:38:55 +0000
commit87a336ab02d10618c52d4492007db99ca27b5f03 (patch)
tree281eba41902d940d67d054f866b85e5a8219fd4b /dev-libs/crypto++/crypto++-5.2.1.ebuild
parentConsolidate *-sharp-2* masks. (diff)
downloadgentoo-2-87a336ab02d10618c52d4492007db99ca27b5f03.tar.gz
gentoo-2-87a336ab02d10618c52d4492007db99ca27b5f03.tar.bz2
gentoo-2-87a336ab02d10618c52d4492007db99ca27b5f03.zip
ensure line endings on test vectors are unix
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-libs/crypto++/crypto++-5.2.1.ebuild')
-rw-r--r--dev-libs/crypto++/crypto++-5.2.1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-libs/crypto++/crypto++-5.2.1.ebuild b/dev-libs/crypto++/crypto++-5.2.1.ebuild
index 525f2d6b7ccb..0e6df4ddaf79 100644
--- a/dev-libs/crypto++/crypto++-5.2.1.ebuild
+++ b/dev-libs/crypto++/crypto++-5.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/crypto++-5.2.1.ebuild,v 1.6 2005/04/22 09:24:09 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/crypto++/crypto++-5.2.1.ebuild,v 1.7 2005/08/17 00:38:55 rphillips Exp $
inherit flag-o-matic eutils
@@ -28,6 +28,11 @@ src_compile() {
src_test() {
+ # make sure all test vectors have unix line endings
+ for f in TestVectors/* ; do
+ edos2unix $f
+ done
+
if ! ./cryptest.exe v
then
eerror "crypto++ self-tests failed"