summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Wever <weeve@gentoo.org>2004-03-25 16:15:15 +0000
committerJason Wever <weeve@gentoo.org>2004-03-25 16:15:15 +0000
commit09eaa0a3a54f00330cab18422e0c57a54d0a975f (patch)
tree6873cbca6f8ef4e8cda78b551de1e126857087d2 /dev-libs/dietlibc
parentVersion bumped. (Manifest recommit) (diff)
downloadgentoo-2-09eaa0a3a54f00330cab18422e0c57a54d0a975f.tar.gz
gentoo-2-09eaa0a3a54f00330cab18422e0c57a54d0a975f.tar.bz2
gentoo-2-09eaa0a3a54f00330cab18422e0c57a54d0a975f.zip
Fix for bug #45601 and adjusted Makefile so that the usage of the sparc32 command isn't needed anymore.
Diffstat (limited to 'dev-libs/dietlibc')
-rw-r--r--dev-libs/dietlibc/ChangeLog7
-rw-r--r--dev-libs/dietlibc/dietlibc-0.24.ebuild27
-rw-r--r--dev-libs/dietlibc/files/dietlibc-sparc64-makefile.patch11
3 files changed, 25 insertions, 20 deletions
diff --git a/dev-libs/dietlibc/ChangeLog b/dev-libs/dietlibc/ChangeLog
index e5edae29b149..70bd2b5e7b0b 100644
--- a/dev-libs/dietlibc/ChangeLog
+++ b/dev-libs/dietlibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/dietlibc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dietlibc/ChangeLog,v 1.26 2004/02/20 02:51:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dietlibc/ChangeLog,v 1.27 2004/03/25 16:15:15 weeve Exp $
+
+ 25 Mar 2004; Jason Wever <weeve@gentoo.org> dietlibc-0.24.ebuild,
+ files/dietlibc-sparc64-makefile.patch:
+ Fix for bug #45601 and adjusted Makefile so that the usage of the sparc32
+ command isn't needed anymore.
19 Feb 2004; Michael Sterrett <mr_bones_@gentoo.org> dietlibc-0.23.ebuild,
dietlibc-0.24.ebuild, files/gcc-33.patch:
diff --git a/dev-libs/dietlibc/dietlibc-0.24.ebuild b/dev-libs/dietlibc/dietlibc-0.24.ebuild
index 1b8dc508df4c..8ce2d604d277 100644
--- a/dev-libs/dietlibc/dietlibc-0.24.ebuild
+++ b/dev-libs/dietlibc/dietlibc-0.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dietlibc/dietlibc-0.24.ebuild,v 1.6 2004/02/20 02:51:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dietlibc/dietlibc-0.24.ebuild,v 1.7 2004/03/25 16:15:15 weeve Exp $
inherit eutils flag-o-matic fixheadtails gcc
@@ -31,35 +31,24 @@ src_unpack() {
-e "s:^#DESTDIR=.*:DESTDIR=${D}:" Makefile || \
die "sed Makefile failed"
+ # New fix for sparc64 and dietlibc, fixes bug #45601
+ [ "${PROFILE_ARCH}" = "sparc64" ] && \
+ epatch ${FILESDIR}/dietlibc-sparc64-makefile.patch
+
ht_fix_all
}
src_compile() {
filter-flags "-fstack-protector"
- # Added by Jason Wever <weeve@gentoo.org>
- # Fix for bug #27171.
- # dietlibc assumes that if uname -m is sparc64, then gcc is 64 bit
- # but this is not the case on Gentoo currently.
-
- if [ "${ARCH}" = "sparc" -a "${PROFILE_ARCH}" = "sparc64" ]; then
- cd ${S}
- /usr/bin/sparc32 make || die "make failed"
- else
- emake || die "emake failed"
- fi
+ emake || die "emake failed"
}
src_install() {
- if [ "${ARCH}" = "sparc" -a "${PROFILE_ARCH}" = "sparc64" ]; then
- cd ${S}
- /usr/bin/sparc32 make install || die "make install failed"
- else
- make install || die "make install failed"
- fi
+ make install || die "make install failed"
exeinto /usr/bin
- newexe bin-$(uname -m | sed -e 's/i[4-9]86/i386/' -e 's/armv[3-6][lb]/arm/')/diet-i diet || die "newexe failed"
+ newexe bin-$(uname -m | sed -e 's/i[4-9]86/i386/' -e 's/armv[3-6][lb]/arm/' -e 's/sparc64/sparc/')/diet-i diet || die "newexe failed"
doman diet.1 || die "doman failed"
dodoc AUTHOR BUGS CAVEAT CHANGES README THANKS TODO PORTING || \
diff --git a/dev-libs/dietlibc/files/dietlibc-sparc64-makefile.patch b/dev-libs/dietlibc/files/dietlibc-sparc64-makefile.patch
new file mode 100644
index 000000000000..d72015214267
--- /dev/null
+++ b/dev-libs/dietlibc/files/dietlibc-sparc64-makefile.patch
@@ -0,0 +1,11 @@
+--- Makefile.orig 2004-03-25 08:24:20.420425000 -0700
++++ Makefile 2004-03-25 08:27:02.730425000 -0700
+@@ -8,7 +8,7 @@
+ BINDIR=${prefix}/bin
+ MAN1DIR=${prefix}/man/man1
+
+-MYARCH:=$(shell uname -m | sed -e 's/i[4-9]86/i386/' -e 's/armv[3-6][lb]/arm/')
++MYARCH:=$(shell uname -m | sed -e 's/i[4-9]86/i386/' -e 's/armv[3-6][lb]/arm/' -e 's/sparc64/sparc/')
+
+ # This extra-ugly cruft is here so make will not run uname and sed each
+ # time it looks at $(OBJDIR). This alone sped up running make when