summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-05-27 13:36:52 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-05-27 13:36:52 +0000
commit55d1acf27c82c7b5585fe8fe7c989d48ce98885f (patch)
tree7a0eff9e10268b9c27cafc116c431e0b929b4585 /dev-libs/galib
parentinitial import (Manifest recommit) (diff)
downloadgentoo-2-55d1acf27c82c7b5585fe8fe7c989d48ce98885f.tar.gz
gentoo-2-55d1acf27c82c7b5585fe8fe7c989d48ce98885f.tar.bz2
gentoo-2-55d1acf27c82c7b5585fe8fe7c989d48ce98885f.zip
Fixing bug #51821 (gcc 3.3 compilation problems)
Diffstat (limited to 'dev-libs/galib')
-rw-r--r--dev-libs/galib/ChangeLog8
-rw-r--r--dev-libs/galib/files/galib-2.4.5-gcc3.3.patch12
-rw-r--r--dev-libs/galib/galib-2.4.5.ebuild17
3 files changed, 33 insertions, 4 deletions
diff --git a/dev-libs/galib/ChangeLog b/dev-libs/galib/ChangeLog
index aa3220e91f1d..02b1c07bb827 100644
--- a/dev-libs/galib/ChangeLog
+++ b/dev-libs/galib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/galib
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/galib/ChangeLog,v 1.2 2003/10/18 07:19:40 vapier Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/galib/ChangeLog,v 1.3 2004/05/27 13:36:52 phosphan Exp $
+
+ 27 May 2004; Patrick Kursawe <phosphan@gentoo.org> galib-2.4.5.ebuild,
+ files/galib-2.4.5-gcc3.3.patch:
+ Fixing bug #51821 (gcc 3.3 compilation problems)
*galib-2.4.5 (16 Oct 2003)
diff --git a/dev-libs/galib/files/galib-2.4.5-gcc3.3.patch b/dev-libs/galib/files/galib-2.4.5-gcc3.3.patch
new file mode 100644
index 000000000000..bba1dc122c90
--- /dev/null
+++ b/dev-libs/galib/files/galib-2.4.5-gcc3.3.patch
@@ -0,0 +1,12 @@
+--- ga/GARealGenome.h 2004-05-27 14:51:05.239072957 +0200
++++ ga/GARealGenome.h 2004-05-27 15:02:21.824011198 +0200
+@@ -18,6 +18,9 @@
+ typedef GAAlleleSet<float> GARealAlleleSet;
+ typedef GAAlleleSetArray<float> GARealAlleleSetArray;
+
++float GAAlleleSet<float>::allele() const;
++float GAAlleleSet<float>::allele(unsigned) const;
++
+ typedef GA1DArrayAlleleGenome<float> GARealGenome;
+
+ inline void GARealUniformInitializer(GAGenome& g){
diff --git a/dev-libs/galib/galib-2.4.5.ebuild b/dev-libs/galib/galib-2.4.5.ebuild
index 24c15f856a82..5ea5b3f43074 100644
--- a/dev-libs/galib/galib-2.4.5.ebuild
+++ b/dev-libs/galib/galib-2.4.5.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/galib/galib-2.4.5.ebuild,v 1.2 2003/11/21 07:07:42 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/galib/galib-2.4.5.ebuild,v 1.3 2004/05/27 13:36:52 phosphan Exp $
+
+inherit eutils
DESCRIPTION="library for using genetic algorithms in C++ programs"
@@ -14,6 +16,17 @@ DEPEND=">=sys-apps/sed-4"
S=${WORKDIR}/galib245
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc3.3.patch
+ for file in examples/*.C ga/gaconfig.h; do
+ for thing in iostream fstream; do
+ sed -e "s:${thing}.h:${thing}:" -i ${file};
+ done
+ done
+}
+
src_compile() {
make CXXFLAGS="${CXXFLAGS}" || die "make failed"
}