summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-01-17 00:29:31 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-01-17 00:29:31 +0000
commit177807fbf97f93a9374a6b3258c66c9062db92a6 (patch)
treea00ce57974bbf342f8957881ae6bb83ff00bbd41 /dev-libs/geoip/geoip-1.4.0-r1.ebuild
parentFix sed expression. (bug #160328) (diff)
downloadgentoo-2-177807fbf97f93a9374a6b3258c66c9062db92a6.tar.gz
gentoo-2-177807fbf97f93a9374a6b3258c66c9062db92a6.tar.bz2
gentoo-2-177807fbf97f93a9374a6b3258c66c9062db92a6.zip
Adding vuln fix wrt bug #161288
(Portage version: 2.1.2_rc4-r8)
Diffstat (limited to 'dev-libs/geoip/geoip-1.4.0-r1.ebuild')
-rw-r--r--dev-libs/geoip/geoip-1.4.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/geoip/geoip-1.4.0-r1.ebuild b/dev-libs/geoip/geoip-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..d2e49b42fadd
--- /dev/null
+++ b/dev-libs/geoip/geoip-1.4.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/geoip-1.4.0-r1.ebuild,v 1.1 2007/01/17 00:29:31 jokey Exp $
+
+inherit autotools eutils libtool
+
+MY_P="${P/geoip/GeoIP}"
+DESCRIPTION="easily lookup countries by IP addresses, even when Reverse DNS entries don't exist"
+HOMEPAGE="http://www.maxmind.com/geoip/api/c.shtml"
+SRC_URI="http://www.maxmind.com/download/geoip/api/c/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-asneeded.patch"
+ epatch "${FILESDIR}/${P}-update-vulnerability.patch"
+ eautomake
+
+ elibtoolize
+}
+
+src_compile() {
+ econf --enable-shared || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "einstall failed"
+}