summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-22 17:53:08 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-22 17:53:08 +0000
commit9ff114fd6e6c38753419cb0c0e107bb085646522 (patch)
tree849b407e3e4140df5b0aef2177292e395a9a6404 /dev-libs/gjs
parentVersion bump, drop old (diff)
downloadgentoo-2-9ff114fd6e6c38753419cb0c0e107bb085646522.tar.gz
gentoo-2-9ff114fd6e6c38753419cb0c0e107bb085646522.tar.bz2
gentoo-2-9ff114fd6e6c38753419cb0c0e107bb085646522.zip
Version bump
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs/gjs')
-rw-r--r--dev-libs/gjs/ChangeLog7
-rw-r--r--dev-libs/gjs/gjs-1.36.1.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-libs/gjs/ChangeLog b/dev-libs/gjs/ChangeLog
index 498d0e7f9d95..f8c424076fea 100644
--- a/dev-libs/gjs/ChangeLog
+++ b/dev-libs/gjs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/gjs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gjs/ChangeLog,v 1.19 2013/03/28 16:44:24 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gjs/ChangeLog,v 1.20 2013/04/22 17:53:08 pacho Exp $
+
+*gjs-1.36.1 (22 Apr 2013)
+
+ 22 Apr 2013; Pacho Ramos <pacho@gentoo.org> +gjs-1.36.1.ebuild:
+ Version bump
*gjs-1.36.0 (28 Mar 2013)
diff --git a/dev-libs/gjs/gjs-1.36.1.ebuild b/dev-libs/gjs/gjs-1.36.1.ebuild
new file mode 100644
index 000000000000..97100dd66ec6
--- /dev/null
+++ b/dev-libs/gjs/gjs-1.36.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gjs/gjs-1.36.1.ebuild,v 1.1 2013/04/22 17:53:08 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 pax-utils virtualx
+
+DESCRIPTION="Javascript bindings for GNOME"
+HOMEPAGE="http://live.gnome.org/Gjs"
+
+LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
+SLOT="0"
+IUSE="+cairo examples"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.36.0:2
+ >=dev-libs/gobject-introspection-1.36.0
+
+ dev-libs/dbus-glib
+ sys-libs/readline
+ >=dev-lang/spidermonkey-1.8.5
+ virtual/libffi
+ cairo? ( x11-libs/cairo )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ # AUTHORS, ChangeLog are empty
+ DOCS="NEWS README"
+
+ # FIXME: add systemtap/dtrace support, like in glib:2
+ # FIXME: --enable-systemtap installs files in ${D}/${D} for some reason
+ # XXX: Do NOT enable coverage, completely useless for portage installs
+ gnome2_src_configure \
+ --disable-systemtap \
+ --disable-dtrace \
+ --disable-coverage \
+ $(use_with cairo cairo)
+}
+
+src_test() {
+ # Tests need dbus
+ Xemake check
+}
+
+src_install() {
+ # installation sometimes fails in parallel
+ gnome2_src_install -j1
+
+ if use examples; then
+ insinto /usr/share/doc/"${PF}"/examples
+ doins "${S}"/examples/*
+ fi
+
+ # Required for gjs-console to run correctly on PaX systems
+ pax-mark mr "${ED}/usr/bin/gjs-console"
+}