summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-02-22 16:29:03 +0000
committerAron Griffis <agriffis@gentoo.org>2003-02-22 16:29:03 +0000
commit0542f1899d3819f3b1b57eeedc253732640300c2 (patch)
tree3629a6f7253f5e94990a1ed07b85275cdf5ffc8a /dev-libs/gmp/gmp-4.1.2.ebuild
parentAdded hppa to keywords. (diff)
downloadgentoo-2-0542f1899d3819f3b1b57eeedc253732640300c2.tar.gz
gentoo-2-0542f1899d3819f3b1b57eeedc253732640300c2.tar.bz2
gentoo-2-0542f1899d3819f3b1b57eeedc253732640300c2.zip
update to latest version
Diffstat (limited to 'dev-libs/gmp/gmp-4.1.2.ebuild')
-rw-r--r--dev-libs/gmp/gmp-4.1.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/gmp/gmp-4.1.2.ebuild b/dev-libs/gmp/gmp-4.1.2.ebuild
new file mode 100644
index 000000000000..f418c49efc50
--- /dev/null
+++ b/dev-libs/gmp/gmp-4.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-4.1.2.ebuild,v 1.1 2003/02/22 16:29:03 agriffis Exp $
+
+DESCRIPTION="Library for arithmetic on arbitrary precision integers, rational numbers, and floating-point numbers"
+SRC_URI="mirror://gnu/gmp/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/gmp/gmp.html"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+SLOT="0"
+LICENSE="LGPL-2"
+
+DEPEND=">=sys-devel/m4-1.4p"
+
+src_compile() {
+ local myconf=""
+ use sparc || myconf="--enable-mpfr"
+
+ econf \
+ --localstatedir=/var/state/gmp \
+ --enable-cxx \
+ --enable-mpbsd \
+ ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+ make check || die "make check failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ dodoc AUTHORS ChangeLog COPYING* NEWS README
+ dodoc doc/configuration doc/isa_abi_headache
+ dohtml -r doc
+}