summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-01-12 15:24:19 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-01-12 15:24:19 +0000
commit312d20edcbc903766548ca3355462c04ede22b64 (patch)
treefe8518c935a0d0f7a7cc48159ef3b2ad85e15903 /dev-libs/gsl
parentUpdated to 0.7 (diff)
downloadgentoo-2-312d20edcbc903766548ca3355462c04ede22b64.tar.gz
gentoo-2-312d20edcbc903766548ca3355462c04ede22b64.tar.bz2
gentoo-2-312d20edcbc903766548ca3355462c04ede22b64.zip
added gsl 1.0, initial ebuild
Diffstat (limited to 'dev-libs/gsl')
-rw-r--r--dev-libs/gsl/files/digest-gsl-1.01
-rw-r--r--dev-libs/gsl/gsl-1.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/gsl/files/digest-gsl-1.0 b/dev-libs/gsl/files/digest-gsl-1.0
new file mode 100644
index 000000000000..41680e269503
--- /dev/null
+++ b/dev-libs/gsl/files/digest-gsl-1.0
@@ -0,0 +1 @@
+MD5 eea06ef5d34f74b542534cfa17c938a5 gsl-1.0.tar.gz 2019328
diff --git a/dev-libs/gsl/gsl-1.0.ebuild b/dev-libs/gsl/gsl-1.0.ebuild
new file mode 100644
index 000000000000..a1dc0aa35a8a
--- /dev/null
+++ b/dev-libs/gsl/gsl-1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gsl/gsl-1.0.ebuild,v 1.1 2002/01/12 15:24:19 verwilst Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="The GNU Scientific Library"
+
+SRC_URI="http://mirrors.rcn.net/pub/sourceware/gsl/${P}.tar.gz"
+
+HOMEPAGE="http://sources.redhat.com/gsl/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+#Avoid locking (can break parallel builds)
+ local myconf
+ myconf="--disable-libtool-lock"
+
+ ./configure --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ emake || die
+
+#Uncomment the 'make check ...' line if you want to run the test suite.
+#Note that the check.log file will be several megabytes in size.
+# make check > check.log 2>&1 || die
+
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL KNOWN-PROBLEMS MACHINES
+NEWS
+
+}
+
+
+