summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2012-06-01 13:05:15 +0000
committerJory Pratt <anarchy@gentoo.org>2012-06-01 13:05:15 +0000
commita59a4e5463ccd37174d92b3f4dc79445723242b5 (patch)
treed227d19dbfba17e0bb3d196cb5e752172eea9b7b /dev-libs/jemalloc/files
parentStable for amd64, wrt bug #418911 (diff)
downloadgentoo-2-a59a4e5463ccd37174d92b3f4dc79445723242b5.tar.gz
gentoo-2-a59a4e5463ccd37174d92b3f4dc79445723242b5.tar.bz2
gentoo-2-a59a4e5463ccd37174d92b3f4dc79445723242b5.zip
Version bump dev-libs/jemalloc-3.0.0 bug #416243
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/jemalloc/files')
-rw-r--r--dev-libs/jemalloc/files/jemalloc-3.0.0-no-pprof.patch27
-rw-r--r--dev-libs/jemalloc/files/jemalloc-3.0.0-strip-optimization.patch29
-rw-r--r--dev-libs/jemalloc/files/jemalloc-3.0.0_fix_html_install.patch14
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-libs/jemalloc/files/jemalloc-3.0.0-no-pprof.patch b/dev-libs/jemalloc/files/jemalloc-3.0.0-no-pprof.patch
new file mode 100644
index 000000000000..c2fa815ec529
--- /dev/null
+++ b/dev-libs/jemalloc/files/jemalloc-3.0.0-no-pprof.patch
@@ -0,0 +1,27 @@
+diff --git a/Makefile.in b/Makefile.in
+index 6675b59..ce0782f 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -69,7 +69,6 @@ endif
+ LIBJEMALLOC := $(LIBPREFIX)jemalloc$(install_suffix)
+
+ # Lists of files.
+-BINS := $(srcroot)bin/pprof $(objroot)bin/jemalloc.sh
+ CHDRS := $(objroot)include/jemalloc/jemalloc$(install_suffix).h \
+ $(objroot)include/jemalloc/jemalloc_defs$(install_suffix).h
+ CSRCS := $(srcroot)src/jemalloc.c $(srcroot)src/arena.c $(srcroot)src/atomic.c \
+@@ -196,13 +195,6 @@ build_lib_shared: $(DSOS)
+ build_lib_static: $(STATIC_LIBS)
+ build: build_lib_shared build_lib_static
+
+-install_bin:
+- install -d $(BINDIR)
+- @for b in $(BINS); do \
+- echo "install -m 755 $$b $(BINDIR)"; \
+- install -m 755 $$b $(BINDIR); \
+-done
+-
+ install_include:
+ install -d $(INCLUDEDIR)/jemalloc
+ @for h in $(CHDRS); do \
+
diff --git a/dev-libs/jemalloc/files/jemalloc-3.0.0-strip-optimization.patch b/dev-libs/jemalloc/files/jemalloc-3.0.0-strip-optimization.patch
new file mode 100644
index 000000000000..98c09af6277f
--- /dev/null
+++ b/dev-libs/jemalloc/files/jemalloc-3.0.0-strip-optimization.patch
@@ -0,0 +1,29 @@
+diff --git a/configure.ac b/configure.ac
+index a72019e..e366e1c 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -556,23 +556,6 @@ if test "x$enable_debug" = "x1" ; then
+ fi
+ AC_SUBST([enable_debug])
+
+-dnl Only optimize if not debugging.
+-if test "x$enable_debug" = "x0" -a "x$no_CFLAGS" = "xyes" ; then
+- dnl Make sure that an optimization flag was not specified in EXTRA_CFLAGS.
+- optimize="no"
+- echo "$EXTRA_CFLAGS" | grep "\-O" >/dev/null || optimize="yes"
+- if test "x${optimize}" = "xyes" ; then
+- if test "x$GCC" = "xyes" ; then
+- JE_CFLAGS_APPEND([-O3])
+- JE_CFLAGS_APPEND([-funroll-loops])
+- elif test "x$je_cv_msvc" = "xyes" ; then
+- JE_CFLAGS_APPEND([-O2])
+- else
+- JE_CFLAGS_APPEND([-O])
+- fi
+- fi
+-fi
+-
+ dnl Enable statistics calculation by default.
+ AC_ARG_ENABLE([stats],
+ [AS_HELP_STRING([--disable-stats],
+
diff --git a/dev-libs/jemalloc/files/jemalloc-3.0.0_fix_html_install.patch b/dev-libs/jemalloc/files/jemalloc-3.0.0_fix_html_install.patch
new file mode 100644
index 000000000000..0f3026d44c2b
--- /dev/null
+++ b/dev-libs/jemalloc/files/jemalloc-3.0.0_fix_html_install.patch
@@ -0,0 +1,14 @@
+diff --git a/Makefile.in b/Makefile.in
+index 6675b59..3032c6d 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -240,7 +240,7 @@ install_doc_man:
+ install -m 644 $$d $(MANDIR)/man3; \
+ done
+
+-install_doc: install_doc_html install_doc_man
++install_doc: install_doc_man
+
+ install: install_bin install_include install_lib install_doc
+
+