summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-05-22 03:36:15 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-05-22 03:36:15 +0000
commitfac8a967ac2dac4ea41de147efc19519c1e8f4c5 (patch)
treedd25f268a4442620eace22a918e4bbf21363a7b1 /dev-libs/leveldb
parentBump (diff)
downloadgentoo-2-fac8a967ac2dac4ea41de147efc19519c1e8f4c5.tar.gz
gentoo-2-fac8a967ac2dac4ea41de147efc19519c1e8f4c5.tar.bz2
gentoo-2-fac8a967ac2dac4ea41de147efc19519c1e8f4c5.zip
Bump
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/leveldb')
-rw-r--r--dev-libs/leveldb/ChangeLog7
-rw-r--r--dev-libs/leveldb/leveldb-1.10.0.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-libs/leveldb/ChangeLog b/dev-libs/leveldb/ChangeLog
index 103ed10a71c3..2e6af07db5fe 100644
--- a/dev-libs/leveldb/ChangeLog
+++ b/dev-libs/leveldb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/leveldb
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/leveldb/ChangeLog,v 1.10 2013/05/14 11:46:12 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/leveldb/ChangeLog,v 1.11 2013/05/22 03:36:15 patrick Exp $
+
+*leveldb-1.10.0 (22 May 2013)
+
+ 22 May 2013; Patrick Lauer <patrick@gentoo.org> +leveldb-1.10.0.ebuild:
+ Bump
14 May 2013; Agostino Sarubbo <ago@gentoo.org> leveldb-1.9.0-r5.ebuild:
Stable for arm, wrt bug #469342
diff --git a/dev-libs/leveldb/leveldb-1.10.0.ebuild b/dev-libs/leveldb/leveldb-1.10.0.ebuild
new file mode 100644
index 000000000000..9b446f91ca9d
--- /dev/null
+++ b/dev-libs/leveldb/leveldb-1.10.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/leveldb/leveldb-1.10.0.ebuild,v 1.1 2013/05/22 03:36:15 patrick Exp $
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="a fast key-value storage library written at Google"
+HOMEPAGE="http://code.google.com/p/leveldb/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+snappy static-libs +tcmalloc"
+
+DEPEND="tcmalloc? ( dev-util/google-perftools )
+ snappy? (
+ app-arch/snappy
+ static-libs? ( app-arch/snappy[static-libs] )
+ )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # These vars all get picked up by build_detect_platform
+ # which the Makefile runs for us automatically.
+ tc-export AR CC CXX
+ export OPT="-DNDEBUG ${CPPFLAGS}"
+ # Probably needs more filling out
+ export TARGET_OS
+ case ${CHOST} in
+ *) TARGET_OS="Linux";;
+ esac
+ export USE_SNAPPY=$(usex snappy)
+ export USE_TCMALLOC=no
+}
+
+src_compile() {
+ emake $(usex static-libs '' 'LIBRARY=') all libmemenv.a
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ insinto /usr/include
+ doins -r include/* helpers/memenv/memenv.h
+ dolib.so libleveldb*$(get_libname)*
+ use static-libs && dolib.a libleveldb.a
+ dolib.a libmemenv.a
+}