summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2008-03-26 21:46:20 +0000
committerCédric Krier <cedk@gentoo.org>2008-03-26 21:46:20 +0000
commitb3cc736a2c62e3477965b0e5bc9a516dbef2772f (patch)
tree99c7e7a9363f787cf2f9aebfc09c30e7aca8e1b1 /dev-libs/libbeagle
parentversion bump (bug #214692) (diff)
downloadgentoo-2-b3cc736a2c62e3477965b0e5bc9a516dbef2772f.tar.gz
gentoo-2-b3cc736a2c62e3477965b0e5bc9a516dbef2772f.tar.bz2
gentoo-2-b3cc736a2c62e3477965b0e5bc9a516dbef2772f.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-libs/libbeagle')
-rw-r--r--dev-libs/libbeagle/libbeagle-0.3.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libbeagle/libbeagle-0.3.4.ebuild b/dev-libs/libbeagle/libbeagle-0.3.4.ebuild
new file mode 100644
index 000000000000..5da3942bd1ab
--- /dev/null
+++ b/dev-libs/libbeagle/libbeagle-0.3.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbeagle/libbeagle-0.3.4.ebuild,v 1.1 2008/03/26 21:46:20 cedk Exp $
+
+EAPI=1
+
+inherit gnome.org autotools
+
+DESCRIPTION="C and Python bindings for Beagle"
+HOMEPAGE="http://beagle-project.org/"
+
+LICENSE="MIT Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug doc +python"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=dev-libs/libxml2-2.6.19
+ python? ( >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.6 )
+ !<=app-misc/beagle-0.2.18"
+DEPEND="${RDEPEND}
+ doc? ( dev-util/gtk-doc )"
+
+src_compile() {
+ econf \
+ $(use_enable python) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable debug xml-dump)
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed!"
+}