summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-15 17:08:11 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-15 17:08:11 +0000
commitf51c226bedce5312153ca1ace1604a252f3bcc23 (patch)
tree3387a48f9725b0bf4e908a15863d9bcbed1df808 /dev-libs/libbsd
parentRemove PHP_USE. (diff)
downloadgentoo-2-f51c226bedce5312153ca1ace1604a252f3bcc23.tar.gz
gentoo-2-f51c226bedce5312153ca1ace1604a252f3bcc23.tar.bz2
gentoo-2-f51c226bedce5312153ca1ace1604a252f3bcc23.zip
Remove libutil.h (and vis.h) from /usr/include to prevent automagic #include by dev-lang/perl wrt #399001 by Michał Górny
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libbsd')
-rw-r--r--dev-libs/libbsd/ChangeLog10
-rw-r--r--dev-libs/libbsd/libbsd-0.3.0-r1.ebuild56
2 files changed, 64 insertions, 2 deletions
diff --git a/dev-libs/libbsd/ChangeLog b/dev-libs/libbsd/ChangeLog
index 10af236fb65a..233f5f1b3637 100644
--- a/dev-libs/libbsd/ChangeLog
+++ b/dev-libs/libbsd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libbsd
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbsd/ChangeLog,v 1.6 2011/12/15 22:47:02 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbsd/ChangeLog,v 1.7 2012/01/15 17:08:11 ssuominen Exp $
+
+*libbsd-0.3.0-r1 (15 Jan 2012)
+
+ 15 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +libbsd-0.3.0-r1.ebuild:
+ Remove libutil.h (and vis.h) from /usr/include to prevent automagic #include
+ by dev-lang/perl wrt #399001 by Michał Górny
15 Dec 2011; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer due retirement, bug #353461
diff --git a/dev-libs/libbsd/libbsd-0.3.0-r1.ebuild b/dev-libs/libbsd/libbsd-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..eb170702e73c
--- /dev/null
+++ b/dev-libs/libbsd/libbsd-0.3.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libbsd/libbsd-0.3.0-r1.ebuild,v 1.1 2012/01/15 17:08:11 ssuominen Exp $
+
+EAPI=4
+inherit multilib toolchain-funcs
+
+DESCRIPTION="A BSD compatibility library"
+HOMEPAGE="http://libbsd.freedesktop.org/wiki/"
+SRC_URI="http://libbsd.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="BSD BSD-2 BSD-4 ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+pkg_setup() {
+ mylibbsdconf=(
+ AR="$(tc-getAR)"
+ CC="$(tc-getCC)"
+ libdir=/usr/$(get_libdir)
+ usrlibdir=/usr/$(get_libdir)
+ )
+
+ local f="${ROOT}"usr/$(get_libdir)/libbsd.a
+ if ! has_version dev-libs/libbsd; then
+ if [[ -e ${f} ]]; then
+ eerror "You need to remove ${f} by hand or re-emerge sys-libs/glibc first."
+ die "You need to remove ${f} by hand or re-emerge sys-libs/glibc first."
+ fi
+ fi
+}
+
+src_prepare() {
+ # Instead of replacing upstream warning flags, append to them
+ sed -i -e 's:CFLAGS ?= -g:CFLAGS +=:' Makefile || die
+
+ if ! use static-libs; then
+ sed -i \
+ -e '/^libs/s:$(LIB_STATIC)::' \
+ -e 's:install -m644 $(LIB_STATIC):-&:' \
+ Makefile || die
+ fi
+}
+
+src_compile() {
+ emake "${mylibbsdconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" "${mylibbsdconf[@]}" install
+ dodoc ChangeLog README TODO
+
+ # File collision with dev-libs/elfutils and dev-lang/perl build problem wrt #399001
+ rm -f "${ED}"usr/include/{libutil,nlist,vis}.h
+}