summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-07-17 09:44:04 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-07-17 09:44:04 +0000
commit6255ce6bd5e7eb7dd3578a4f5c1a2aeebfa078af (patch)
tree176abf4152b5a30dde98bf6e4688f1c565cd3fc1 /dev-libs/libcoyotl
parentRevision bump: EAPI 5, epatch_user, do not install html docs unconditionally,... (diff)
downloadgentoo-2-6255ce6bd5e7eb7dd3578a4f5c1a2aeebfa078af.tar.gz
gentoo-2-6255ce6bd5e7eb7dd3578a4f5c1a2aeebfa078af.tar.bz2
gentoo-2-6255ce6bd5e7eb7dd3578a4f5c1a2aeebfa078af.zip
Minor QA fixes, add epatch_user, add USE="static-libs"
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-libs/libcoyotl')
-rw-r--r--dev-libs/libcoyotl/ChangeLog5
-rw-r--r--dev-libs/libcoyotl/libcoyotl-3.1.0-r1.ebuild23
2 files changed, 18 insertions, 10 deletions
diff --git a/dev-libs/libcoyotl/ChangeLog b/dev-libs/libcoyotl/ChangeLog
index 3ec5c81f3917..3b3eac2d6344 100644
--- a/dev-libs/libcoyotl/ChangeLog
+++ b/dev-libs/libcoyotl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/libcoyotl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcoyotl/ChangeLog,v 1.13 2013/04/19 02:53:52 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcoyotl/ChangeLog,v 1.14 2013/07/17 09:44:04 pinkbyte Exp $
+
+ 17 Jul 2013; Sergey Popov <pinkbyte@gentoo.org> libcoyotl-3.1.0-r1.ebuild:
+ Minor QA fixes, add epatch_user, add USE="static-libs"
*libcoyotl-3.1.0-r1 (19 Apr 2013)
diff --git a/dev-libs/libcoyotl/libcoyotl-3.1.0-r1.ebuild b/dev-libs/libcoyotl/libcoyotl-3.1.0-r1.ebuild
index 9bc97410a2ae..51cd39995e20 100644
--- a/dev-libs/libcoyotl/libcoyotl-3.1.0-r1.ebuild
+++ b/dev-libs/libcoyotl/libcoyotl-3.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcoyotl/libcoyotl-3.1.0-r1.ebuild,v 1.1 2013/04/19 02:53:52 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcoyotl/libcoyotl-3.1.0-r1.ebuild,v 1.2 2013/07/17 09:44:04 pinkbyte Exp $
EAPI="5"
@@ -9,27 +9,32 @@ inherit eutils autotools
DESCRIPTION="A collection of portable C++ classes."
HOMEPAGE="http://www.coyotegulch.com/products/libcoyotl/"
SRC_URI="http://www.coyotegulch.com/distfiles/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc"
+
+IUSE="doc static-libs"
RDEPEND="media-libs/libpng"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
+DOCS=( AUTHORS ChangeLog NEWS README )
+
src_prepare() {
- epatch "${FILESDIR}/${PV}-gcc-4.3.patch" || die
- epatch "${FILESDIR}/${PV}-gcc-4.7.patch" || die
+ epatch "${FILESDIR}/${PV}-gcc-4.3.patch"
+ epatch "${FILESDIR}/${PV}-gcc-4.7.patch"
+ epatch_user
eautoreconf
}
src_configure() {
- ac_cv_prog_HAVE_DOXYGEN="false" econf || die "econf failed"
+ ac_cv_prog_HAVE_DOXYGEN="false" econf $(use_enable static-libs static)
}
src_compile() {
- emake || die "emake failed"
+ emake
if use doc ; then
cd docs
@@ -38,9 +43,9 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README
+ default
+ prune_libtool_files
if use doc ; then
- dohtml docs/html/* || die
+ dohtml docs/html/*
fi
}