summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-08-20 13:07:41 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-08-20 13:07:41 +0000
commitc54ca1be77f7a06388b392b77bbb79216c7e53c4 (patch)
treebbbcbd121283e65c895fbf154adef203a65bbcbf /dev-libs/libe
parentBlock >ibus-table-1.3.9 to avoid build failure. #426304 (diff)
downloadgentoo-2-c54ca1be77f7a06388b392b77bbb79216c7e53c4.tar.gz
gentoo-2-c54ca1be77f7a06388b392b77bbb79216c7e53c4.tar.bz2
gentoo-2-c54ca1be77f7a06388b392b77bbb79216c7e53c4.zip
Fix getpid / unistd.h issue
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libe')
-rw-r--r--dev-libs/libe/ChangeLog6
-rw-r--r--dev-libs/libe/files/libe-getpid.patch23
-rw-r--r--dev-libs/libe/libe-0.2.7.ebuild8
3 files changed, 35 insertions, 2 deletions
diff --git a/dev-libs/libe/ChangeLog b/dev-libs/libe/ChangeLog
index eb9db537206a..8823b7c47cd6 100644
--- a/dev-libs/libe/ChangeLog
+++ b/dev-libs/libe/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libe
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libe/ChangeLog,v 1.1 2012/08/18 14:09:44 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libe/ChangeLog,v 1.2 2012/08/20 13:07:40 patrick Exp $
+
+ 20 Aug 2012; Patrick Lauer <patrick@gentoo.org> +files/libe-getpid.patch,
+ libe-0.2.7.ebuild:
+ Fix getpid / unistd.h issue
*libe-0.2.7 (18 Aug 2012)
diff --git a/dev-libs/libe/files/libe-getpid.patch b/dev-libs/libe/files/libe-getpid.patch
new file mode 100644
index 000000000000..4b4c9fdea82a
--- /dev/null
+++ b/dev-libs/libe/files/libe-getpid.patch
@@ -0,0 +1,23 @@
+diff -Naur libe-0.2.7/benchmarks/lockfree_hash_map.cc libe-0.2.7-new/benchmarks/lockfree_hash_map.cc
+--- libe-0.2.7/benchmarks/lockfree_hash_map.cc 2011-10-12 04:02:24.000000000 +0200
++++ libe-0.2.7-new/benchmarks/lockfree_hash_map.cc 2012-08-20 14:59:39.135789923 +0200
+@@ -30,6 +30,7 @@
+ // C includes
+ #include <cstdlib>
+ #include <stdint.h>
++#include <unistd.h>
+
+ // C++
+ #include <iostream>
+diff -Naur libe-0.2.7/benchmarks/lockfree_hash_set.cc libe-0.2.7-new/benchmarks/lockfree_hash_set.cc
+--- libe-0.2.7/benchmarks/lockfree_hash_set.cc 2011-08-26 16:24:54.000000000 +0200
++++ libe-0.2.7-new/benchmarks/lockfree_hash_set.cc 2012-08-20 15:00:37.877793998 +0200
+@@ -30,6 +30,7 @@
+ // C includes
+ #include <cstdlib>
+ #include <stdint.h>
++#include <unistd.h>
+
+ // C++
+ #include <iostream>
+
diff --git a/dev-libs/libe/libe-0.2.7.ebuild b/dev-libs/libe/libe-0.2.7.ebuild
index 1bdf40969d36..58d0423073d0 100644
--- a/dev-libs/libe/libe-0.2.7.ebuild
+++ b/dev-libs/libe/libe-0.2.7.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libe/libe-0.2.7.ebuild,v 1.1 2012/08/18 14:09:44 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libe/libe-0.2.7.ebuild,v 1.2 2012/08/20 13:07:40 patrick Exp $
EAPI=4
+inherit eutils
+
DESCRIPTION="Hyperdex libe support library"
HOMEPAGE="http://hyperdex.org"
@@ -15,3 +17,7 @@ IUSE=""
DEPEND="dev-libs/libpo6"
RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/libe-getpid.patch"
+}