summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-09-09 16:55:48 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-09-09 16:55:48 +0000
commitd90a906924bdf1152148610373a023622ba70001 (patch)
treeeb5bec199a7ded47ebd2d5ba111dda4d716f88da /dev-libs/libg15/libg15-1.2.7-r1.ebuild
parentRevision bump in order to remove static library and libtool archive. Bump the... (diff)
downloadgentoo-2-d90a906924bdf1152148610373a023622ba70001.tar.gz
gentoo-2-d90a906924bdf1152148610373a023622ba70001.tar.bz2
gentoo-2-d90a906924bdf1152148610373a023622ba70001.zip
Revision bump in order to remove static library and libtool archive. Bump the eapi to 4.
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-libs/libg15/libg15-1.2.7-r1.ebuild')
-rw-r--r--dev-libs/libg15/libg15-1.2.7-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/libg15/libg15-1.2.7-r1.ebuild b/dev-libs/libg15/libg15-1.2.7-r1.ebuild
new file mode 100644
index 000000000000..efa5ef73412d
--- /dev/null
+++ b/dev-libs/libg15/libg15-1.2.7-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libg15/libg15-1.2.7-r1.ebuild,v 1.1 2011/09/09 16:55:47 scarabeus Exp $
+
+EAPI=4
+
+DESCRIPTION="The libg15 library gives low-level access to the Logitech G15 keyboard"
+HOMEPAGE="http://g15tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/g15tools/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+DEPEND="=virtual/libusb-0*"
+RDEPEND=${DEPEND}
+
+DOCS=( AUTHORS README ChangeLog )
+
+src_configure() {
+ econf \
+ --disable-static
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}