summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-07 14:34:54 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-07 14:34:54 +0000
commit03a01daa8b47ce388555e1b7cdd0c5832c28800c (patch)
treecb430dd36a1f2e6ce4712398378e90b74a65ac95 /dev-libs/libgusb/libgusb-0.1.6.ebuild
parentapp-backup/deja-dup: Add missing eclass phase functions calls (diff)
downloadgentoo-2-03a01daa8b47ce388555e1b7cdd0c5832c28800c.tar.gz
gentoo-2-03a01daa8b47ce388555e1b7cdd0c5832c28800c.tar.bz2
gentoo-2-03a01daa8b47ce388555e1b7cdd0c5832c28800c.zip
Version bump, drop old.
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs/libgusb/libgusb-0.1.6.ebuild')
-rw-r--r--dev-libs/libgusb/libgusb-0.1.6.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/libgusb/libgusb-0.1.6.ebuild b/dev-libs/libgusb/libgusb-0.1.6.ebuild
new file mode 100644
index 000000000000..11df3f165a5c
--- /dev/null
+++ b/dev-libs/libgusb/libgusb-0.1.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgusb/libgusb-0.1.6.ebuild,v 1.1 2013/04/07 14:34:54 pacho Exp $
+
+EAPI=5
+VALA_MIN_API_VERSION="0.16"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils vala
+
+DESCRIPTION="GObject wrapper for libusb"
+HOMEPAGE="https://gitorious.org/gusb/"
+SRC_URI="http://people.freedesktop.org/~hughsient/releases/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection static-libs vala"
+REQUIRED_USE="vala? ( introspection )"
+
+# udev is effectively a required dependency: configuring with --disable-gudev
+# causes build failures
+RDEPEND=">=dev-libs/glib-2.28:2
+ virtual/libusb:1
+ virtual/udev[gudev]
+ introspection? ( >=dev-libs/gobject-introspection-1.29 )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ dev-libs/libxslt
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+# gtk-doc-am needed for proper api docs installation
+
+# Tests try to access usb devices in /dev
+RESTRICT="test"
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(use_enable vala)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}