summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-09-01 17:26:05 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-09-01 17:26:05 +0000
commitfe0ce0f966abb3df5a17ec01ac229d4ffad82b47 (patch)
treed1a20a0f15b7cefc1d7d0e6b6cd3417fb2e3771e /dev-libs/libgweather
parentAdd missing libSM to DEPEND, bug #481094. (diff)
downloadgentoo-2-fe0ce0f966abb3df5a17ec01ac229d4ffad82b47.tar.gz
gentoo-2-fe0ce0f966abb3df5a17ec01ac229d4ffad82b47.tar.bz2
gentoo-2-fe0ce0f966abb3df5a17ec01ac229d4ffad82b47.zip
Re-add libgweather-3.6.2; it's needed for gnome-applets-3.6, evolution-data-server-3.6, etc. (bug #483084, thanks to lluixhi).
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'dev-libs/libgweather')
-rw-r--r--dev-libs/libgweather/ChangeLog7
-rw-r--r--dev-libs/libgweather/libgweather-3.6.2.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-libs/libgweather/ChangeLog b/dev-libs/libgweather/ChangeLog
index 9dbf533364b8..b50dbf355a7d 100644
--- a/dev-libs/libgweather/ChangeLog
+++ b/dev-libs/libgweather/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libgweather
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.96 2013/08/30 21:14:23 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/ChangeLog,v 1.97 2013/09/01 17:26:05 tetromino Exp $
+
+ 01 Sep 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +libgweather-3.6.2.ebuild:
+ Re-add libgweather-3.6.2; it's needed for gnome-applets-3.6,
+ evolution-data-server-3.6, etc. (bug #483084, thanks to lluixhi).
30 Aug 2013; Gilles Dartiguelongue <eva@gentoo.org>
-libgweather-3.6.2.ebuild, -libgweather-3.8.1.ebuild,
diff --git a/dev-libs/libgweather/libgweather-3.6.2.ebuild b/dev-libs/libgweather/libgweather-3.6.2.ebuild
new file mode 100644
index 000000000000..b2d38c1db377
--- /dev/null
+++ b/dev-libs/libgweather/libgweather-3.6.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgweather/libgweather-3.6.2.ebuild,v 1.3 2013/09/01 17:26:04 tetromino Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Library to access weather information from online services"
+HOMEPAGE="https://live.gnome.org/LibGWeather"
+
+LICENSE="GPL-2+"
+SLOT="2/3-1" # subslot = 3-(libgweather-3 soname suffix)
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+
+COMMON_DEPEND="
+ >=x11-libs/gtk+-2.90.0:3[introspection?]
+ >=dev-libs/glib-2.13
+ >=net-libs/libsoup-gnome-2.25.1:2.4
+ >=dev-libs/libxml2-2.6.0
+ >=sys-libs/timezone-data-2010k
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gnome-applets-2.22.0
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS"
+ # Do not add --disable-all-translations-in-one-xml : it will enable them
+ gnome2_src_configure \
+ --enable-locations-compression \
+ --disable-static \
+ $(use_enable introspection)
+}