summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Brannon <teiresias@gentoo.org>2013-10-02 04:26:57 +0000
committerChristopher Brannon <teiresias@gentoo.org>2013-10-02 04:26:57 +0000
commit73ac7d55486f9819df5943b5264e0ce5c4b44b73 (patch)
tree37ed3d4ad04fb590537769cdf189e110779f7344 /dev-libs/liblouis
parentStable for HPPA (bug #475480). (diff)
downloadgentoo-2-73ac7d55486f9819df5943b5264e0ce5c4b44b73.tar.gz
gentoo-2-73ac7d55486f9819df5943b5264e0ce5c4b44b73.tar.bz2
gentoo-2-73ac7d55486f9819df5943b5264e0ce5c4b44b73.zip
Add liblouis from the sunrise overlay. Closes bug #305899.
Thanks to Angelo D'Autilia <sydro@salug.it> for the initial ebuild. (Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x6521e06d)
Diffstat (limited to 'dev-libs/liblouis')
-rw-r--r--dev-libs/liblouis/ChangeLog11
-rw-r--r--dev-libs/liblouis/liblouis-2.5.3.ebuild65
-rw-r--r--dev-libs/liblouis/metadata.xml9
3 files changed, 85 insertions, 0 deletions
diff --git a/dev-libs/liblouis/ChangeLog b/dev-libs/liblouis/ChangeLog
new file mode 100644
index 000000000000..ac34d54cdad9
--- /dev/null
+++ b/dev-libs/liblouis/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-libs/liblouis
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liblouis/ChangeLog,v 1.1 2013/10/02 04:26:57 teiresias Exp $
+
+*liblouis-2.5.3 (01 Oct 2013)
+
+ 01 Oct 2013; Christopher Brannon <teiresias@gentoo.org>
+ +liblouis-2.5.3.ebuild, +metadata.xml:
+ Add liblouis from the sunrise overlay. Closes bug #305899.
+ Thanks to Angelo D'Autilia <sydro@salug.it> for the initial ebuild.
+
diff --git a/dev-libs/liblouis/liblouis-2.5.3.ebuild b/dev-libs/liblouis/liblouis-2.5.3.ebuild
new file mode 100644
index 000000000000..ed4389dfaa4e
--- /dev/null
+++ b/dev-libs/liblouis/liblouis-2.5.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/liblouis/liblouis-2.5.3.ebuild,v 1.1 2013/10/02 04:26:57 teiresias Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+PYTHON_REQ_USE='wide-unicode(+)'
+DISTUTILS_OPTIONAL=1
+inherit distutils-r1
+
+DESCRIPTION="An open-source braille translator and back-translator"
+HOMEPAGE="http://code.google.com/p/liblouis/"
+SRC_URI="http://liblouis.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python"
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+src_prepare() {
+ default
+
+ if use python; then
+ pushd python > /dev/null
+ distutils-r1_src_prepare
+ popd > /dev/null
+ fi
+}
+
+src_configure() {
+ econf --enable-ucs4
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ pushd python > /dev/null
+ # setup.py imports liblouis to get the version number,
+ # and this causes the shared library to be dlopened
+ # at build-time. Hack around it with LD_PRELOAD.
+ # Thanks ArchLinux.
+ LD_PRELOAD+=':../liblouis/.libs/liblouis.so'
+ distutils-r1_src_compile
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ if use python; then
+ pushd python > /dev/null
+ LD_PRELOAD+=':../liblouis/.libs/liblouis.so' \
+ distutils-r1_src_install
+ popd > /dev/null
+ fi
+
+ dodoc README AUTHORS NEWS ChangeLog || die
+ dohtml doc/liblouis.html
+}
diff --git a/dev-libs/liblouis/metadata.xml b/dev-libs/liblouis/metadata.xml
new file mode 100644
index 000000000000..d030e2893d9b
--- /dev/null
+++ b/dev-libs/liblouis/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<maintainer>
+ <email>teiresias@gentoo.org</email>
+ <name>Chris Brannon</name>
+</maintainer>
+</pkgmetadata>