summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-08-10 17:52:37 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-08-10 17:52:37 +0000
commita060acfaac0166cfd5ba42fc0e0cb0c18044f7ee (patch)
treef263d51c859c85e7d8094f045b3018683bbf429c /dev-libs/libmcrypt/libmcrypt-2.5.8-r2.ebuild
parentMarking bugzilla-3.2.7 ppc64 for bug 329923 (diff)
downloadgentoo-2-a060acfaac0166cfd5ba42fc0e0cb0c18044f7ee.tar.gz
gentoo-2-a060acfaac0166cfd5ba42fc0e0cb0c18044f7ee.tar.bz2
gentoo-2-a060acfaac0166cfd5ba42fc0e0cb0c18044f7ee.zip
Migrate changes from Gentoo Prefix overlay. Add eautoreconf, KEYWORDS. bug 331973
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libmcrypt/libmcrypt-2.5.8-r2.ebuild')
-rw-r--r--dev-libs/libmcrypt/libmcrypt-2.5.8-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libmcrypt/libmcrypt-2.5.8-r2.ebuild b/dev-libs/libmcrypt/libmcrypt-2.5.8-r2.ebuild
new file mode 100644
index 000000000000..31807249e014
--- /dev/null
+++ b/dev-libs/libmcrypt/libmcrypt-2.5.8-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmcrypt/libmcrypt-2.5.8-r2.ebuild,v 1.1 2010/08/10 17:52:37 darkside Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="libmcrypt is a library that provides uniform interface to access several encryption algorithms."
+HOMEPAGE="http://mcrypt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mcrypt/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-rotate-mask.patch
+ eautoreconf # need new libtool for interix (elibtoolize would suffice for freebsd)
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "install failure"
+
+ dodoc AUTHORS NEWS README THANKS TODO ChangeLog
+ dodoc doc/README.* doc/example.c
+ prepalldocs
+}