summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-02-03 04:00:53 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-02-03 04:00:53 +0000
commitc6588d1d9cf3292f2deccbb7fb2743cf97fcda71 (patch)
tree513fead5d497901c7a507ca77240b570dcbd503e /dev-libs/libowfat/libowfat-0.16.ebuild
parentAdded a few patches that should of been there originally (diff)
downloadgentoo-2-c6588d1d9cf3292f2deccbb7fb2743cf97fcda71.tar.gz
gentoo-2-c6588d1d9cf3292f2deccbb7fb2743cf97fcda71.tar.bz2
gentoo-2-c6588d1d9cf3292f2deccbb7fb2743cf97fcda71.zip
version bump
Diffstat (limited to 'dev-libs/libowfat/libowfat-0.16.ebuild')
-rw-r--r--dev-libs/libowfat/libowfat-0.16.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libowfat/libowfat-0.16.ebuild b/dev-libs/libowfat/libowfat-0.16.ebuild
new file mode 100644
index 000000000000..e24b01c69f89
--- /dev/null
+++ b/dev-libs/libowfat/libowfat-0.16.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libowfat/libowfat-0.16.ebuild,v 1.1 2004/02/03 04:00:35 dragonheart Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="reimplement libdjb - excellent libraries from Dan Bernstein."
+SRC_URI="http://www.fefe.de/libowfat/${P}.tar.bz2"
+HOMEPAGE="http://www.fefe.de/libowfat/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=dev-libs/dietlibc-0.22"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ mv GNUmakefile GNUmakefile.orig
+ sed -e "s:^CFLAGS.*:CFLAGS=-I. ${CFLAGS}:" \
+ -e "s:^DIET.*:DIET=/usr/bin/diet -Os:" \
+ -e "s:^prefix.*:prefix=/usr:" \
+ -e "s:^INCLUDEDIR.*:INCLUDEDIR=\${prefix}/include/libowfat:" \
+ GNUmakefile.orig > GNUmakefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ make \
+ LIBDIR=${D}/usr/lib \
+ MAN3DIR=${D}/usr/share/man/man3 \
+ INCLUDEDIR=${D}/usr/include/libowfat \
+ install || die
+}