summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2014-06-07 18:40:15 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2014-06-07 18:40:15 +0000
commit42f05e526836714e2ce0468612b5b0a70b3976c6 (patch)
treefd03e520d2fa3cfbaa8b510d3050f8b217c6ebef /dev-libs/libtasn1
parentFix CVE-2014-3466, CVE-2014-3467, CVE-2014-3468, CVE-2014-3469 of 2.12 series (diff)
downloadgentoo-2-42f05e526836714e2ce0468612b5b0a70b3976c6.tar.gz
gentoo-2-42f05e526836714e2ce0468612b5b0a70b3976c6.tar.bz2
gentoo-2-42f05e526836714e2ce0468612b5b0a70b3976c6.zip
Version bump, bug#511536
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'dev-libs/libtasn1')
-rw-r--r--dev-libs/libtasn1/ChangeLog8
-rw-r--r--dev-libs/libtasn1/files/libtasn1-3.6-build.patch49
-rw-r--r--dev-libs/libtasn1/libtasn1-3.6.ebuild46
3 files changed, 102 insertions, 1 deletions
diff --git a/dev-libs/libtasn1/ChangeLog b/dev-libs/libtasn1/ChangeLog
index 22d88fc04d64..9917be2d62a0 100644
--- a/dev-libs/libtasn1/ChangeLog
+++ b/dev-libs/libtasn1/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libtasn1
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtasn1/ChangeLog,v 1.199 2014/05/28 07:21:40 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtasn1/ChangeLog,v 1.200 2014/06/07 18:40:15 alonbl Exp $
+
+*libtasn1-3.6 (07 Jun 2014)
+
+ 07 Jun 2014; Alon Bar-Lev <alonbl@gentoo.org> +files/libtasn1-3.6-build.patch,
+ +libtasn1-3.6.ebuild:
+ Version bump, bug#511536
28 May 2014; Sergey Popov <pinkbyte@gentoo.org> libtasn1-3.4-r1.ebuild:
Add ~amd64-linux keyword
diff --git a/dev-libs/libtasn1/files/libtasn1-3.6-build.patch b/dev-libs/libtasn1/files/libtasn1-3.6-build.patch
new file mode 100644
index 000000000000..f72029cf17b3
--- /dev/null
+++ b/dev-libs/libtasn1/files/libtasn1-3.6-build.patch
@@ -0,0 +1,49 @@
+From 895e00804990040e252d93093c7c2adcdfa3efa5 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Sat, 7 Jun 2014 21:36:30 +0300
+Subject: [PATCH] build: tests: fix Test_choice within separate builddir
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ tests/Makefile.am | 2 +-
+ tests/Test_choice.c | 6 +++++-
+ 2 files changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/tests/Makefile.am b/tests/Makefile.am
+index d6c850a..4762a69 100644
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -44,7 +44,7 @@ TESTS = Test_parser Test_tree Test_encoding Test_indefinite \
+ TESTS_ENVIRONMENT = \
+ ASN1PARSER=$(srcdir)/Test_parser.asn \
+ ASN1TREE=$(srcdir)/Test_tree.asn \
+- ASN1PKIX=$(srcdir)/pkix.asn \
++ ASN1CHOICE=$(srcdir)/choice.asn \
+ ASN1PKIX=$(srcdir)/pkix.asn \
+ ASN1CRLDER=$(srcdir)/crl.der \
+ ASN1INDEF=$(srcdir)/TestIndef.p12 \
+diff --git a/tests/Test_choice.c b/tests/Test_choice.c
+index 07da57e..8a0b5c1 100644
+--- a/tests/Test_choice.c
++++ b/tests/Test_choice.c
+@@ -8,12 +8,16 @@ main (int argc, char** argv)
+ int result = 0;
+ asn1_node definitions = NULL, node1 = NULL, node2 = NULL;
+ char errorDescription[ASN1_MAX_ERROR_DESCRIPTION_SIZE];
++ const char *choicefile = getenv ("ASN1CHOICE");
+
+ char data[1024];
+ int data_size = sizeof (data);
+
++ if (!choicefile)
++ choicefile = "choice.asn";
++
+ /* Encode */
+- result = asn1_parser2tree ("choice.asn", &definitions, errorDescription);
++ result = asn1_parser2tree (choicefile, &definitions, errorDescription);
+ if (result != ASN1_SUCCESS)
+ {
+ printf ("error in %d\n", __LINE__);
+--
+1.8.5.5
+
diff --git a/dev-libs/libtasn1/libtasn1-3.6.ebuild b/dev-libs/libtasn1/libtasn1-3.6.ebuild
new file mode 100644
index 000000000000..f51300745027
--- /dev/null
+++ b/dev-libs/libtasn1/libtasn1-3.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtasn1/libtasn1-3.6.ebuild,v 1.1 2014/06/07 18:40:15 alonbl Exp $
+
+EAPI=5
+
+inherit autotools autotools-multilib
+
+DESCRIPTION="ASN.1 library"
+HOMEPAGE="http://www.gnu.org/software/libtasn1/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-2.1"
+SLOT="0/6" # subslot = libtasn1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos"
+IUSE="doc static-libs"
+
+DEPEND=">=dev-lang/perl-5.6
+ virtual/yacc"
+RDEPEND="
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20131008-r16
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs
+ [[ "${VALGRIND_TESTS}" == "0" ]] && myeconfargs+=( --disable-valgrind-tests )
+ autotools-multilib_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install
+
+ if use doc ; then
+ dodoc doc/libtasn1.pdf
+ dohtml doc/reference/html/*
+ fi
+}