summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-06-10 02:58:09 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-06-10 02:58:09 +0000
commit8005d21d0f3cc8994fadecd3e97cd550b9baa545 (patch)
tree872e9865a45d509147c6284042bafe7c3ce5b097 /dev-libs/libtomcrypt
parentVersion bump. bug #162161. Thanks to hawking & Rafa# Mu#y#o for the contribut... (diff)
downloadgentoo-2-8005d21d0f3cc8994fadecd3e97cd550b9baa545.tar.gz
gentoo-2-8005d21d0f3cc8994fadecd3e97cd550b9baa545.tar.bz2
gentoo-2-8005d21d0f3cc8994fadecd3e97cd550b9baa545.zip
Version bump, bug #162164. Thanks to hawking and Perttu Luukko for the ebuilds
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-libs/libtomcrypt')
-rw-r--r--dev-libs/libtomcrypt/ChangeLog9
-rw-r--r--dev-libs/libtomcrypt/libtomcrypt-1.17.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-libs/libtomcrypt/ChangeLog b/dev-libs/libtomcrypt/ChangeLog
index b75828375bad..5ce7592a31a2 100644
--- a/dev-libs/libtomcrypt/ChangeLog
+++ b/dev-libs/libtomcrypt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libtomcrypt
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/ChangeLog,v 1.27 2006/04/27 17:01:12 marienz Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/ChangeLog,v 1.28 2008/06/10 02:58:09 darkside Exp $
+
+*libtomcrypt-1.17 (10 Jun 2008)
+
+ 10 Jun 2008; Jeremy Olexa <darkside@gentoo.org> +libtomcrypt-1.17.ebuild:
+ Version bump, bug #162164. Thanks to hawking and Perttu Luukko for the ebuilds
27 Apr 2006; Marien Zwart <marienz@gentoo.org>
files/digest-libtomcrypt-1.03, files/digest-libtomcrypt-1.06, Manifest:
diff --git a/dev-libs/libtomcrypt/libtomcrypt-1.17.ebuild b/dev-libs/libtomcrypt/libtomcrypt-1.17.ebuild
new file mode 100644
index 000000000000..3b46a911d125
--- /dev/null
+++ b/dev-libs/libtomcrypt/libtomcrypt-1.17.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/libtomcrypt-1.17.ebuild,v 1.1 2008/06/10 02:58:09 darkside Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="modular and portable cryptographic toolkit"
+HOMEPAGE="http://libtom.org/?page=features&whatfile=crypt"
+SRC_URI="http://libtom.org/files/crypt-${PV}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc libtommath tomsfastmath"
+
+RDEPEND="libtommath? ( dev-libs/libtommath )
+ tomsfastmath? ( dev-libs/tomsfastmath )
+ !libtommath? ( !tomsfastmath? ( dev-libs/libtommath ) )"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base virtual/ghostscript )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ use doc || sed -i '/^install:/s:docs::' makefile
+}
+
+src_compile() {
+ use libtommath && append-flags -DLTM_DESC
+ use tomsfastmath && append-flags -DTFM_DESC
+ emake IGNORE_SPEED=1 || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc TODO changes
+ if use doc ; then
+ dodoc doc/*
+ docinto notes ; dodoc notes/*
+ docinto demos ; dodoc demos/*
+ fi
+}