summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-01-16 04:16:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-01-16 04:16:55 +0000
commit1f79468e169d763e1aac563eee4101754b12940a (patch)
tree86f518d0430ff4b64237e65a5d44933a372f5c44 /dev-libs/libuv
parentStable on amd64 and x86 for 527558 (diff)
downloadgentoo-2-1f79468e169d763e1aac563eee4101754b12940a.tar.gz
gentoo-2-1f79468e169d763e1aac563eee4101754b12940a.tar.bz2
gentoo-2-1f79468e169d763e1aac563eee4101754b12940a.zip
Bump
(Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/libuv')
-rw-r--r--dev-libs/libuv/ChangeLog9
-rw-r--r--dev-libs/libuv/libuv-1.2.1.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-libs/libuv/ChangeLog b/dev-libs/libuv/ChangeLog
index aa17e0c714e7..bb0258819aaf 100644
--- a/dev-libs/libuv/ChangeLog
+++ b/dev-libs/libuv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libuv
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/ChangeLog,v 1.28 2014/12/30 15:23:33 hasufell Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/ChangeLog,v 1.29 2015/01/16 04:16:55 patrick Exp $
+
+*libuv-1.2.1 (16 Jan 2015)
+
+ 16 Jan 2015; Patrick Lauer <patrick@gentoo.org> +libuv-1.2.1.ebuild:
+ Bump
*libuv-1.1.0 (30 Dec 2014)
diff --git a/dev-libs/libuv/libuv-1.2.1.ebuild b/dev-libs/libuv/libuv-1.2.1.ebuild
new file mode 100644
index 000000000000..0916ff8cc7ae
--- /dev/null
+++ b/dev-libs/libuv/libuv-1.2.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/libuv-1.2.1.ebuild,v 1.1 2015/01/16 04:16:55 patrick Exp $
+
+EAPI=5
+
+inherit eutils autotools multilib-minimal
+
+DESCRIPTION="A new platform layer for Node"
+HOMEPAGE="https://github.com/joyent/libuv"
+SRC_URI="https://github.com/libuv/libuv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD BSD-2 ISC MIT"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" \
+ > m4/libuv-extra-automake-flags.m4 || die
+
+ sed -i \
+ -e '/libuv_la_CFLAGS/s#-g##' \
+ Makefile.am || die "fixing CFLAGS failed!"
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ mkdir "${BUILD_DIR}"/test || die
+ cp -pPR "${S}"/test/fixtures "${BUILD_DIR}"/test/fixtures || die
+ default
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}