summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-08-26 01:11:15 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-08-26 01:11:15 +0000
commit2854f085676e7ba6c8c6ac890260ba92b5fd8741 (patch)
tree44f7d7e97d323abca92c9c77926843fcd3be31cf /dev-libs/libuv
parentAdd note about pypy for previous change (diff)
downloadgentoo-2-2854f085676e7ba6c8c6ac890260ba92b5fd8741.tar.gz
gentoo-2-2854f085676e7ba6c8c6ac890260ba92b5fd8741.tar.bz2
gentoo-2-2854f085676e7ba6c8c6ac890260ba92b5fd8741.zip
version bump
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-libs/libuv')
-rw-r--r--dev-libs/libuv/ChangeLog7
-rw-r--r--dev-libs/libuv/libuv-0.11.10.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-libs/libuv/ChangeLog b/dev-libs/libuv/ChangeLog
index 0f027bbd7d61..6de02915f482 100644
--- a/dev-libs/libuv/ChangeLog
+++ b/dev-libs/libuv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libuv
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/ChangeLog,v 1.5 2013/08/23 10:33:47 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/ChangeLog,v 1.6 2013/08/26 01:11:15 hasufell Exp $
+
+*libuv-0.11.10 (26 Aug 2013)
+
+ 26 Aug 2013; Julian Ospald <hasufell@gentoo.org> +libuv-0.11.10.ebuild:
+ version bump
23 Aug 2013; Julian Ospald <hasufell@gentoo.org> libuv-0.11.8.ebuild,
-files/libuv-0.11.8-Werror.patch:
diff --git a/dev-libs/libuv/libuv-0.11.10.ebuild b/dev-libs/libuv/libuv-0.11.10.ebuild
new file mode 100644
index 000000000000..263b91ac2819
--- /dev/null
+++ b/dev-libs/libuv/libuv-0.11.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libuv/libuv-0.11.10.ebuild,v 1.1 2013/08/26 01:11:15 hasufell Exp $
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="A new platform layer for Node"
+HOMEPAGE="https://github.com/joyent/libuv"
+SRC_URI="https://github.com/joyent/libuv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD BSD-2 ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+ echo "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [serial-tests])" \
+ > m4/libuv-extra-automake-flags.m4 || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}