summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-12-11 14:08:00 +0000
committerMarinus Schraal <foser@gentoo.org>2003-12-11 14:08:00 +0000
commit1adc1210e14d479974f2b4383fa55420b75a8608 (patch)
tree933416e3394a67923429d7890a2dbe3cfd3b23c9 /dev-libs/libxml2/libxml2-2.6.3.ebuild
parentnew release 'n cleanup (diff)
downloadgentoo-2-1adc1210e14d479974f2b4383fa55420b75a8608.tar.gz
gentoo-2-1adc1210e14d479974f2b4383fa55420b75a8608.tar.bz2
gentoo-2-1adc1210e14d479974f2b4383fa55420b75a8608.zip
new release 'n cleanup
Diffstat (limited to 'dev-libs/libxml2/libxml2-2.6.3.ebuild')
-rw-r--r--dev-libs/libxml2/libxml2-2.6.3.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-libs/libxml2/libxml2-2.6.3.ebuild b/dev-libs/libxml2/libxml2-2.6.3.ebuild
new file mode 100644
index 000000000000..75b4cceb270b
--- /dev/null
+++ b/dev-libs/libxml2/libxml2-2.6.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxml2/libxml2-2.6.3.ebuild,v 1.1 2003/12/11 14:07:49 foser Exp $
+
+inherit libtool gnome.org flag-o-matic
+
+DESCRIPTION="Version 2 of the library to manipulate XML files"
+HOMEPAGE="http://www.xmlsoft.org/"
+LICENSE="MIT"
+
+IUSE="python readline ipv6"
+SLOT="2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64"
+
+DEPEND="sys-libs/zlib
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )"
+
+src_compile() {
+
+ # filter seemingly problematic CFLAGS (#26320)
+ filter-flags -fprefetch-loop-arrays -funroll-loops
+
+ # USE zlib support breaks gnome2
+ # (libgnomeprint for instance fails to compile with
+ # fresh install, and existing) - <azarah@gentoo.org> (22 Dec 2002).
+
+ econf --with-zlib \
+ `use_with python` \
+ `use_with readline` \
+ `use_enable ipv6` || die
+
+ emake || die
+
+}
+
+src_install() {
+
+ make \
+ DESTDIR=${D} \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/python/example \
+ BASE_DIR=/usr/share/doc \
+ DOC_MODULE=${PF} \
+ EXAMPLES_DIR=/usr/share/doc/${PF}/example \
+ TARGET_DIR=/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc AUTHORS Copyright ChangeLog INSTALL NEWS README TODO
+
+}
+
+pkg_postinst() {
+
+ # need an XML catalog, so no-one writes to a non-existent one
+ CATALOG=/etc/xml/catalog
+ # we dont want to clobber an existing catalog though,
+ # only ensure that one is there
+ # <obz@gentoo.org>
+ if [ ! -e ${CATALOG} ]; then
+ [ -d /etc/xml ] || mkdir /etc/xml
+ /usr/bin/xmlcatalog --create > ${CATALOG}
+ einfo "Created XML catalog in ${CATALOG}"
+ fi
+
+}
+