summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-02-17 14:58:54 +0000
committerMarinus Schraal <foser@gentoo.org>2004-02-17 14:58:54 +0000
commitf41bdbd508d8c65079fcf1ae4b4d718393fe57a0 (patch)
treef5bece62aa556bb5968eef8f83a18261e0566353 /dev-libs/libxslt/libxslt-1.1.3.ebuild
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-f41bdbd508d8c65079fcf1ae4b4d718393fe57a0.tar.gz
gentoo-2-f41bdbd508d8c65079fcf1ae4b4d718393fe57a0.tar.bz2
gentoo-2-f41bdbd508d8c65079fcf1ae4b4d718393fe57a0.zip
new release
Diffstat (limited to 'dev-libs/libxslt/libxslt-1.1.3.ebuild')
-rw-r--r--dev-libs/libxslt/libxslt-1.1.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/libxslt/libxslt-1.1.3.ebuild b/dev-libs/libxslt/libxslt-1.1.3.ebuild
new file mode 100644
index 000000000000..334ad2d93aac
--- /dev/null
+++ b/dev-libs/libxslt/libxslt-1.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.3.ebuild,v 1.1 2004/02/17 14:58:54 foser Exp $
+
+inherit libtool gnome.org
+
+IUSE="python"
+DESCRIPTION="XSLT libraries and tools"
+HOMEPAGE="http://www.xmlsoft.org/"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64"
+
+DEPEND=">=dev-libs/libxml2-2.6.5
+ python? ( dev-lang/python )"
+
+src_compile() {
+
+ elibtoolize
+
+ econf $(use_with python) || die "configure failed"
+
+ emake || die "make failed"
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/python/example \
+ BASE_DIR=/usr/share/doc \
+ DOC_MODULE=${PF} \
+ EXAMPLES_DIR=/usr/share/doc/${PF}/example \
+ TARGET_DIR=/usr/share/doc/${PF}/html \
+ install || die "install failed"
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+
+}