summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-06-28 18:17:27 +0000
committerJohannes Huber <johu@gentoo.org>2013-06-28 18:17:27 +0000
commit85eb318cd39f824888b663d299c31b8c86ef444b (patch)
tree681d877a70fab0a173dac1c701044c1a5b1f9ca5 /dev-libs/libzip
parentVersion bump. (diff)
downloadgentoo-2-85eb318cd39f824888b663d299c31b8c86ef444b.tar.gz
gentoo-2-85eb318cd39f824888b663d299c31b8c86ef444b.tar.bz2
gentoo-2-85eb318cd39f824888b663d299c31b8c86ef444b.zip
Version bump.
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'dev-libs/libzip')
-rw-r--r--dev-libs/libzip/ChangeLog7
-rw-r--r--dev-libs/libzip/libzip-0.11.1.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-libs/libzip/ChangeLog b/dev-libs/libzip/ChangeLog
index e5d8df1268c5..e7356912e0cc 100644
--- a/dev-libs/libzip/ChangeLog
+++ b/dev-libs/libzip/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libzip
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libzip/ChangeLog,v 1.65 2013/06/25 17:17:21 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libzip/ChangeLog,v 1.66 2013/06/28 18:17:27 johu Exp $
+
+*libzip-0.11.1 (28 Jun 2013)
+
+ 28 Jun 2013; Johannes Huber <johu@gentoo.org> +libzip-0.11.1.ebuild:
+ Version bump.
25 Jun 2013; Johannes Huber <johu@gentoo.org>
-files/libzip-0.10-fix_pkgconfig.patch,
diff --git a/dev-libs/libzip/libzip-0.11.1.ebuild b/dev-libs/libzip/libzip-0.11.1.ebuild
new file mode 100644
index 000000000000..28163f5226a4
--- /dev/null
+++ b/dev-libs/libzip/libzip-0.11.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libzip/libzip-0.11.1.ebuild,v 1.1 2013/06/28 18:17:26 johu Exp $
+
+EAPI=5
+
+MY_P=${P/_}
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils eutils
+
+DESCRIPTION="Library for manipulating zip archives"
+HOMEPAGE="http://www.nih.at/libzip/"
+SRC_URI="http://www.nih.at/libzip/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+DOCS=( NEWS README THANKS AUTHORS )
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.10_rc1-fix_headers.patch"
+ "${FILESDIR}/${PN}-0.11-fix_pkgconfig.patch"
+)
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+RESTRICT="test"
+
+src_prepare() {
+ autotools-utils_src_prepare
+ # run due to fix_headers patch
+ AT_NOELIBTOOLIZE=yes eautoreconf
+ #elibtoolize # FreeBSD .so version
+
+ # fix test return state
+ sed -i \
+ -e 's:19/2:19/0:' \
+ regress/open_nonarchive.test || die
+}
+
+src_install() {
+ autotools-utils_src_install
+ prune_libtool_files --all
+}
+
+src_test() {
+ #Having VERBOSE as an env variable causes the fread test to fail (bug 421651)
+ unset VERBOSE
+ autotools-utils_src_test
+}