summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2008-01-08 00:31:48 +0000
committerCarsten Lohrke <carlo@gentoo.org>2008-01-08 00:31:48 +0000
commit0f122aa2534719fb738ece90aaa1ffa92aa460b8 (patch)
treec86f1a91b0c1a7eb5c5a543997a855b07d8b15b5 /dev-libs/mini-xml/mini-xml-2.4.ebuild
parentnew license for dev-libs/mini-xml (diff)
downloadgentoo-2-0f122aa2534719fb738ece90aaa1ffa92aa460b8.tar.gz
gentoo-2-0f122aa2534719fb738ece90aaa1ffa92aa460b8.tar.bz2
gentoo-2-0f122aa2534719fb738ece90aaa1ffa92aa460b8.zip
Version bump.
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-libs/mini-xml/mini-xml-2.4.ebuild')
-rw-r--r--dev-libs/mini-xml/mini-xml-2.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/mini-xml/mini-xml-2.4.ebuild b/dev-libs/mini-xml/mini-xml-2.4.ebuild
new file mode 100644
index 000000000000..7f1eb4270958
--- /dev/null
+++ b/dev-libs/mini-xml/mini-xml-2.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mini-xml/mini-xml-2.4.ebuild,v 1.1 2008/01/08 00:31:47 carlo Exp $
+
+inherit autotools multilib
+
+MY_P="${P/mini-xml/mxml}"
+
+DESCRIPTION="Mini-XML is a small XML parsing library that you can use to read XML and XML-like data files in your application without requiring large non-standard libraries."
+HOMEPAGE="http://www.easysw.com/~mike/mxml"
+SRC_URI="http://ftp.easysw.com/pub/mxml/${PV}/${MY_P}.tar.gz"
+
+LICENSE="Mini-XML"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+DEPEND="dev-util/pkgconfig"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+
+src_test() {
+ emake testmxml
+}
+
+src_compile() {
+ sed -i -e "s:755 -s:755:" Makefile.in || die "sed failed"
+ rm configure
+ eautoreconf
+
+ econf --enable-shared --libdir="/usr/$(get_libdir)" --with-docdir="/usr/share/doc/${PF}/html"
+ emake libmxml.a libmxml.so.1.4 mxmldoc doc/mxml.man
+}
+
+src_install() {
+ emake DSTROOT="${D}" install || die "install failed"
+ dodoc ANNOUNCEMENT CHANGES README
+ rm "${D}/usr/share/doc/${PF}/html/"{CHANGES,COPYING,README}
+}