summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-01-03 22:17:27 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-01-03 22:17:27 +0000
commit8219398a6e74537d38a192e8daf2fb57f1928184 (patch)
tree7020138515e53f5caee7f079393d13c16ca70b99 /dev-libs/openssl/openssl-0.9.7c-r1.ebuild
parentver bump #36007 (diff)
downloadgentoo-2-8219398a6e74537d38a192e8daf2fb57f1928184.tar.gz
gentoo-2-8219398a6e74537d38a192e8daf2fb57f1928184.tar.bz2
gentoo-2-8219398a6e74537d38a192e8daf2fb57f1928184.zip
Closing #35283
Diffstat (limited to 'dev-libs/openssl/openssl-0.9.7c-r1.ebuild')
-rw-r--r--dev-libs/openssl/openssl-0.9.7c-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-libs/openssl/openssl-0.9.7c-r1.ebuild b/dev-libs/openssl/openssl-0.9.7c-r1.ebuild
index d5bfccf18b4e..f0a2ccf16f91 100644
--- a/dev-libs/openssl/openssl-0.9.7c-r1.ebuild
+++ b/dev-libs/openssl/openssl-0.9.7c-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7c-r1.ebuild,v 1.9 2003/12/23 23:29:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7c-r1.ebuild,v 1.10 2004/01/03 22:17:18 aliz Exp $
inherit eutils flag-o-matic gcc
@@ -48,7 +48,7 @@ src_unpack() {
if [ "$(gcc-version)" == "3.3" ] || [ "$(gcc-version)" == "3.2" ] ; then
filter-flags -fprefetch-loop-arrays
fi
- sed -i -e "s/-O3/$CFLAGS/" -e "s/-m486//" Configure
+ sed -i -r -e "s/-O[23]/$CFLAGS/" -e "s/-fomit-frame-pointer//" -e "s/-mcpu=[a-z0-9]+//" -e "s/-m486//" Configure
# openssl-0.9.6
test -f ${ROOT}/usr/lib/libssl.so.0.9.6 && {
@@ -75,7 +75,7 @@ src_unpack() {
sed -i -e 's/parisc-\*-linux2/parisc\*-\*-linux2/' config
esac
- sed -i -e "s/-O3/$CFLAGS/" -e "s/-m486//" Configure
+ sed -i -e "s/-O[23]/$CFLAGS/" -e "s/-fomit-frame-pointer//" -e -r "s/\-mcpu=[a-z0-9]+//" -e "s/-m486//" Configure
}
}