summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-06 22:01:50 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-06 22:01:50 +0000
commit8c0a09992cf5a2754b3abaf2b967dcce13c68c67 (patch)
treec70bdbc14bd81ca7f9c49bf04858a6fc0f26c3db /dev-libs/openssl/openssl-0.9.7c-r1.ebuild
parentVersion bump (Manifest recommit) (diff)
downloadgentoo-2-8c0a09992cf5a2754b3abaf2b967dcce13c68c67.tar.gz
gentoo-2-8c0a09992cf5a2754b3abaf2b967dcce13c68c67.tar.bz2
gentoo-2-8c0a09992cf5a2754b3abaf2b967dcce13c68c67.zip
Fix use invocation
Diffstat (limited to 'dev-libs/openssl/openssl-0.9.7c-r1.ebuild')
-rw-r--r--dev-libs/openssl/openssl-0.9.7c-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-libs/openssl/openssl-0.9.7c-r1.ebuild b/dev-libs/openssl/openssl-0.9.7c-r1.ebuild
index 9ba0dee83bab..1270af146f55 100644
--- a/dev-libs/openssl/openssl-0.9.7c-r1.ebuild
+++ b/dev-libs/openssl/openssl-0.9.7c-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7c-r1.ebuild,v 1.24 2004/04/19 19:10:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.7c-r1.ebuild,v 1.25 2004/06/06 22:01:50 agriffis Exp $
inherit eutils flag-o-matic
@@ -108,7 +108,7 @@ src_compile() {
cd ${WORKDIR}/${P}
# Build correctly for mips, mips64, & mipsel
- if [ "`use mips`" ]; then
+ if use mips; then
if [ "`echo ${CHOST} | grep "mipsel"`" ]; then
mipsarch="linux-mipsel"
else
@@ -132,7 +132,7 @@ src_compile() {
einfo "Compiling ${P}"
make all || die
- if [ "`use !ppc64`" ]; then
+ if ! use ppc64; then
make test || die
fi
@@ -145,7 +145,7 @@ src_compile() {
SSH_TARGET="linux-sparcv8"
elif [ "`uname -m`" = "parisc" -o "`uname -m`" = "parisc64" ]; then
SSH_TARGET="linux-parisc"
- elif [ "`use mips`" ]; then
+ elif use mips; then
if [ "`echo ${CHOST} | grep "mipsel"`" ]; then
SSH_TARGET="linux-mipsel"
else