summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-10-31 20:21:25 +0000
committerMike Frysinger <vapier@gentoo.org>2011-10-31 20:21:25 +0000
commite12d0a3ce8509af5917f09b3fbbb7f7e68f6c417 (patch)
tree07629578b3d139b97d4f860570563bb0cc993301 /dev-libs/openssl/openssl-0.9.8r.ebuild
parentAnother underlinking fix, bug 387609 (diff)
downloadgentoo-2-e12d0a3ce8509af5917f09b3fbbb7f7e68f6c417.tar.gz
gentoo-2-e12d0a3ce8509af5917f09b3fbbb7f7e68f6c417.tar.bz2
gentoo-2-e12d0a3ce8509af5917f09b3fbbb7f7e68f6c417.zip
Update to EAPI=2 to keep down differences with newer openssl ebuilds, and fix path to enginedir in multilib setup.
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/openssl/openssl-0.9.8r.ebuild')
-rw-r--r--dev-libs/openssl/openssl-0.9.8r.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-libs/openssl/openssl-0.9.8r.ebuild b/dev-libs/openssl/openssl-0.9.8r.ebuild
index 4e50a6bbd341..03936876dbbb 100644
--- a/dev-libs/openssl/openssl-0.9.8r.ebuild
+++ b/dev-libs/openssl/openssl-0.9.8r.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.8r.ebuild,v 1.5 2011/07/05 07:01:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.8r.ebuild,v 1.6 2011/10/31 20:21:25 vapier Exp $
# this ebuild is only for the libcrypto.so.0.9.8 and libssl.so.0.9.8 SONAME for ABI compat
-EAPI="1"
+EAPI="2"
inherit eutils flag-o-matic toolchain-funcs
@@ -34,10 +34,7 @@ pkg_setup() {
fi
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/${PN}-0.9.8e-bsd-sparc64.patch
epatch "${FILESDIR}"/${PN}-0.9.8h-ldflags.patch #181438
epatch "${FILESDIR}"/${PN}-0.9.8m-binutils.patch #289130
@@ -56,6 +53,10 @@ src_unpack() {
|| die
# show the actual commands in the log
sed -i '/^SET_X/s:=.*:=set -x:' Makefile.shared
+ # update the enginedir path
+ sed -i \
+ -e "/foo.*engines/s|/lib/engines|/$(get_libdir)/engines|" \
+ Configure || die
# allow openssl to be cross-compiled
cp "${FILESDIR}"/gentoo.config-0.9.8 gentoo.config || die "cp cross-compile failed"
@@ -69,7 +70,7 @@ src_unpack() {
./config --test-sanity || die "I AM NOT SANE"
}
-src_compile() {
+src_configure() {
unset APPS #197996
unset SCRIPTS #312551
@@ -123,7 +124,9 @@ src_compile() {
-e "/^CFLAG/s|=.*|=${CFLAG} ${CFLAGS}|" \
-e "/^SHARED_LDFLAGS=/s|$| ${LDFLAGS}|" \
Makefile || die
+}
+src_compile() {
# depend is needed to use $confopts
emake -j1 depend || die "depend failed"
emake -j1 build_libs || die "make build_libs failed"