summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-03-16 03:39:10 +0000
committerMike Frysinger <vapier@gentoo.org>2011-03-16 03:39:10 +0000
commitb444a5d95ab6d7c405e2c293efce675c91c2f181 (patch)
tree6e93bc3c20ef6b4c28ff2928bada3dba2d13c1bf /dev-libs/openssl
parentold (diff)
downloadgentoo-2-b444a5d95ab6d7c405e2c293efce675c91c2f181.tar.gz
gentoo-2-b444a5d95ab6d7c405e2c293efce675c91c2f181.tar.bz2
gentoo-2-b444a5d95ab6d7c405e2c293efce675c91c2f181.zip
Tweak sed to use | for separator #358771 by Raffaello D. Di Napoli.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/openssl')
-rw-r--r--dev-libs/openssl/ChangeLog6
-rw-r--r--dev-libs/openssl/openssl-0.9.8r.ebuild8
-rw-r--r--dev-libs/openssl/openssl-1.0.0d.ebuild6
3 files changed, 12 insertions, 8 deletions
diff --git a/dev-libs/openssl/ChangeLog b/dev-libs/openssl/ChangeLog
index a9f85774c45f..9054817caae6 100644
--- a/dev-libs/openssl/ChangeLog
+++ b/dev-libs/openssl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/openssl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.393 2011/03/05 15:10:02 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/ChangeLog,v 1.394 2011/03/16 03:39:10 vapier Exp $
+
+ 16 Mar 2011; Mike Frysinger <vapier@gentoo.org> openssl-0.9.8r.ebuild,
+ openssl-1.0.0d.ebuild:
+ Tweak sed to use | for separator #358771 by Raffaello D. Di Napoli.
05 Mar 2011; Raúl Porcel <armin76@gentoo.org> openssl-1.0.0d.ebuild:
ia64/s390/sh/sparc stable wrt #354139
diff --git a/dev-libs/openssl/openssl-0.9.8r.ebuild b/dev-libs/openssl/openssl-0.9.8r.ebuild
index 44fd426fb72e..212363016880 100644
--- a/dev-libs/openssl/openssl-0.9.8r.ebuild
+++ b/dev-libs/openssl/openssl-0.9.8r.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.8r.ebuild,v 1.3 2011/02/24 20:37:19 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.8r.ebuild,v 1.4 2011/03/16 03:39:10 vapier Exp $
# this ebuild is only for the libcrypto.so.0.9.8 and libssl.so.0.9.8 SONAME for ABI compat
@@ -120,9 +120,9 @@ src_compile() {
-e 's:-m[a-z0-9]* ::g' \
)
sed -i \
- -e "/^LIBDIR=/s:=.*:=$(get_libdir):" \
- -e "/^CFLAG/s:=.*:=${CFLAG} ${CFLAGS}:" \
- -e "/^SHARED_LDFLAGS=/s:$: ${LDFLAGS}:" \
+ -e "/^LIBDIR=/s|=.*|=$(get_libdir)|" \
+ -e "/^CFLAG/s|=.*|=${CFLAG} ${CFLAGS}|" \
+ -e "/^SHARED_LDFLAGS=/s|$| ${LDFLAGS}|" \
Makefile || die
# depend is needed to use $confopts
diff --git a/dev-libs/openssl/openssl-1.0.0d.ebuild b/dev-libs/openssl/openssl-1.0.0d.ebuild
index ab9bcd329c86..421899d35aa6 100644
--- a/dev-libs/openssl/openssl-1.0.0d.ebuild
+++ b/dev-libs/openssl/openssl-1.0.0d.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.0d.ebuild,v 1.8 2011/03/05 15:10:02 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-1.0.0d.ebuild,v 1.9 2011/03/16 03:39:10 vapier Exp $
EAPI="2"
@@ -115,8 +115,8 @@ src_configure() {
-e 's:-m[a-z0-9]* ::g' \
)
sed -i \
- -e "/^CFLAG/s:=.*:=${CFLAG} ${CFLAGS}:" \
- -e "/^SHARED_LDFLAGS=/s:$: ${LDFLAGS}:" \
+ -e "/^CFLAG/s|=.*|=${CFLAG} ${CFLAGS}|" \
+ -e "/^SHARED_LDFLAGS=/s|$| ${LDFLAGS}|" \
Makefile || die
}