summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-12 22:40:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-12 22:40:55 +0000
commit0e5a7487fd331e3b7c44891a60fca2d4ca835edf (patch)
treebedf99b9ff5eda3336b2485eccb61a69bf19b739 /dev-libs/protobuf
parentUse new functionality of DISTUTILS_SETUP_FILES. (diff)
downloadgentoo-2-0e5a7487fd331e3b7c44891a60fca2d4ca835edf.tar.gz
gentoo-2-0e5a7487fd331e3b7c44891a60fca2d4ca835edf.tar.bz2
gentoo-2-0e5a7487fd331e3b7c44891a60fca2d4ca835edf.zip
Use new functionality of DISTUTILS_SETUP_FILES.
(Portage version: 2.2.0_alpha29_p17/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/protobuf')
-rw-r--r--dev-libs/protobuf/protobuf-2.4.0a.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/dev-libs/protobuf/protobuf-2.4.0a.ebuild b/dev-libs/protobuf/protobuf-2.4.0a.ebuild
index d5467b585017..d6d153dc95dd 100644
--- a/dev-libs/protobuf/protobuf-2.4.0a.ebuild
+++ b/dev-libs/protobuf/protobuf-2.4.0a.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.4.0a.ebuild,v 1.1 2011/02/12 22:19:02 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf/protobuf-2.4.0a.ebuild,v 1.2 2011/04/12 22:40:55 arfrever Exp $
EAPI="3"
JAVA_PKG_IUSE="source"
PYTHON_DEPEND="python? 2"
+DISTUTILS_SRC_TEST="setup.py"
-inherit autotools eutils distutils python java-pkg-opt-2 elisp-common
+inherit autotools eutils distutils java-pkg-opt-2 elisp-common
DESCRIPTION="Google's Protocol Buffers -- an efficient method of encoding structured data"
HOMEPAGE="http://code.google.com/p/protobuf/"
@@ -24,8 +25,8 @@ DEPEND="${DEPEND} java? ( >=virtual/jdk-1.5 )
RDEPEND="${RDEPEND} java? ( >=virtual/jre-1.5 )
emacs? ( virtual/emacs )"
+DISTUTILS_SETUP_FILES=("python|setup.py")
PYTHON_MODNAME="google/protobuf"
-DISTUTILS_SRC_TEST="setup.py"
pkg_setup() {
if use python; then
@@ -54,9 +55,7 @@ src_compile() {
if use python; then
einfo "Compiling Python library ..."
- pushd python
distutils_src_compile
- popd
fi
if use java; then
@@ -78,9 +77,7 @@ src_test() {
emake check || die "emake check failed"
if use python; then
- pushd python
distutils_src_test
- popd
fi
}
@@ -91,9 +88,7 @@ src_install() {
use static-libs || rm -rf "${D}"/usr/lib*/*.la
if use python; then
- pushd python
distutils_src_install
- popd
fi
if use java; then