summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-09-01 09:40:39 +0000
committerChristian Heim <phreak@gentoo.org>2007-09-01 09:40:39 +0000
commit76d6c6f55130edc8d3315d29babc364f88212ce8 (patch)
tree605d5e9f6ca7692a56509e1df3657f83d740950e /dev-libs/redland
parentVersion bump. No major groundbreakery. Masked due to dep on (diff)
downloadgentoo-2-76d6c6f55130edc8d3315d29babc364f88212ce8.tar.gz
gentoo-2-76d6c6f55130edc8d3315d29babc364f88212ce8.tar.bz2
gentoo-2-76d6c6f55130edc8d3315d29babc364f88212ce8.zip
Fixing compilation on FreeBSD (thanks to Toffanin [WiredTEK] <equilibrium at gechi.it> in #190682 for the patch).
(Portage version: 2.1.3.7)
Diffstat (limited to 'dev-libs/redland')
-rw-r--r--dev-libs/redland/ChangeLog7
-rw-r--r--dev-libs/redland/files/redland-1.0.6-fbsd.patch13
-rw-r--r--dev-libs/redland/redland-1.0.6.ebuild3
3 files changed, 21 insertions, 2 deletions
diff --git a/dev-libs/redland/ChangeLog b/dev-libs/redland/ChangeLog
index d9899148f6d4..a56881f56533 100644
--- a/dev-libs/redland/ChangeLog
+++ b/dev-libs/redland/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/redland
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/redland/ChangeLog,v 1.22 2007/06/14 07:52:15 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/redland/ChangeLog,v 1.23 2007/09/01 09:40:39 phreak Exp $
+
+ 01 Sep 2007; Christian Heim <phreak@gentoo.org>
+ +files/redland-1.0.6-fbsd.patch, redland-1.0.6.ebuild:
+ Fixing compilation on FreeBSD (thanks to Toffanin [WiredTEK] <equilibrium at
+ gechi.it> in #190682 for the patch).
14 Jun 2007; Christian Heim <phreak@gentoo.org> redland-1.0.4.ebuild,
redland-1.0.5.ebuild, redland-1.0.6.ebuild:
diff --git a/dev-libs/redland/files/redland-1.0.6-fbsd.patch b/dev-libs/redland/files/redland-1.0.6-fbsd.patch
new file mode 100644
index 000000000000..0ea5712f2335
--- /dev/null
+++ b/dev-libs/redland/files/redland-1.0.6-fbsd.patch
@@ -0,0 +1,13 @@
+--- redland-1.0.6/librdf/rdf_init_internal.h 2007-08-29 19:43:08 +0200
++++ redland-1.0.6/librdf/rdf_init_internal.h 2007-08-29 19:43:32 +0200
+@@ -28,6 +28,10 @@
+ #ifndef LIBRDF_INIT_INTERNAL_H
+ #define LIBRDF_INIT_INTERNAL_H
+
++#ifdef WITH_THREADS
++#include <pthread.h>
++#endif
++
+ #ifdef __cplusplus
+ extern "C" {
+ #endif
diff --git a/dev-libs/redland/redland-1.0.6.ebuild b/dev-libs/redland/redland-1.0.6.ebuild
index f0cfadbedde5..7a1fd3e7517f 100644
--- a/dev-libs/redland/redland-1.0.6.ebuild
+++ b/dev-libs/redland/redland-1.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/redland/redland-1.0.6.ebuild,v 1.2 2007/06/14 07:52:15 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/redland/redland-1.0.6.ebuild,v 1.3 2007/09/01 09:40:39 phreak Exp $
inherit eutils
@@ -24,6 +24,7 @@ DEPEND="mysql? ( virtual/mysql )
src_unpack() {
unpack ${A}
rm -r "${S}"/{raptor,rasqal}
+ epatch "${FILESDIR}"/${P}-fbsd.patch
}
src_compile() {