summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-04-25 18:45:54 +0000
committerPacho Ramos <pacho@gentoo.org>2013-04-25 18:45:54 +0000
commit095e4d427b30da6699feefc24da9902ea4519e03 (patch)
treee16df20837df457d8db77cf8c8d36206bbcfbbd6 /dev-libs/seed
parentFix autoreconf failures with automake-1.13 (bug #467206). (diff)
downloadgentoo-2-095e4d427b30da6699feefc24da9902ea4519e03.tar.gz
gentoo-2-095e4d427b30da6699feefc24da9902ea4519e03.tar.bz2
gentoo-2-095e4d427b30da6699feefc24da9902ea4519e03.zip
Version bump
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'dev-libs/seed')
-rw-r--r--dev-libs/seed/ChangeLog7
-rw-r--r--dev-libs/seed/seed-3.8.1.ebuild90
2 files changed, 96 insertions, 1 deletions
diff --git a/dev-libs/seed/ChangeLog b/dev-libs/seed/ChangeLog
index 8c33f05361f7..52580959b126 100644
--- a/dev-libs/seed/ChangeLog
+++ b/dev-libs/seed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/seed
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/seed/ChangeLog,v 1.14 2013/02/02 22:27:32 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/seed/ChangeLog,v 1.15 2013/04/25 18:45:54 pacho Exp $
+
+*seed-3.8.1 (25 Apr 2013)
+
+ 25 Apr 2013; Pacho Ramos <pacho@gentoo.org> +seed-3.8.1.ebuild:
+ Version bump
02 Feb 2013; Agostino Sarubbo <ago@gentoo.org> seed-3.2.0-r1.ebuild:
Add ~arm, wrt bug #449220
diff --git a/dev-libs/seed/seed-3.8.1.ebuild b/dev-libs/seed/seed-3.8.1.ebuild
new file mode 100644
index 000000000000..67d4344ea015
--- /dev/null
+++ b/dev-libs/seed/seed-3.8.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/seed/seed-3.8.1.ebuild,v 1.1 2013/04/25 18:45:54 pacho Exp $
+
+EAPI=5
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="Javascript bindings for Webkit-GTK and GNOME libraries"
+HOMEPAGE="http://live.gnome.org/Seed"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug profile test"
+
+RDEPEND="
+ >=dev-libs/gobject-introspection-1
+ dev-libs/glib:2
+ virtual/libffi
+ x11-libs/cairo
+ x11-libs/gtk+:3[introspection]
+ net-libs/webkit-gtk:3
+ gnome-base/gnome-js-common
+ dev-db/sqlite:3
+ dev-libs/dbus-glib
+ dev-libs/mpfr
+ dev-libs/libxml2:2
+ sys-apps/dbus
+ sys-libs/readline
+ x11-libs/libXScrnSaver
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+ >=dev-util/intltool-0.35
+ profile? ( sys-devel/gcc )
+"
+
+# Lots of tests fail: https://bugzilla.gnome.org/show_bug.cgi?id=660644
+RESTRICT="test"
+
+src_prepare() {
+ if use profile && has ccache ${FEATURES}; then
+ ewarn "USE=profile behaves very badly with ccache; it tries to create"
+ ewarn "profiling data in CCACHE_DIR. Please disable one of them!"
+ fi
+}
+
+src_configure() {
+ # configure behaves very strangely and enables profiling if we pass either
+ # --disable-profile or --enable-profile
+ if use profile; then
+ G2CONF="${G2CONF}
+ --enable-profile
+ --enable-profile-modules"
+ if ! use debug; then
+ einfo "USE=profile needs debug, auto-enabling..."
+ G2CONF="${G2CONF} --enable-debug"
+ fi
+ fi
+
+ gnome2_src_configure \
+ --disable-static \
+ --with-webkit=3.0 \
+ --enable-readline-module \
+ --enable-os-module \
+ --enable-ffi-module \
+ --enable-gtkbuilder-module \
+ --enable-cairo-module \
+ --enable-gettext-module \
+ --enable-dbus-module \
+ --enable-mpfr-module \
+ --enable-sqlite-module \
+ --enable-libxml-module \
+ --enable-xorg-module \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}/html"
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+ # Don't install two copies of standard doc files
+ rm "${ED}/usr/share/doc/${PF}/html/"{AUTHORS,ChangeLog,COPYING,INSTALL,README} || die
+}