summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-02-09 01:19:26 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-02-09 01:19:26 +0000
commit7117ac361ee79957f22dc467fe39f69e77fa983b (patch)
tree4dd8a360c524fc19d6a0ab6441b5a85d524c5792 /dev-libs/wayland
parentFix test file removal. (diff)
downloadgentoo-2-7117ac361ee79957f22dc467fe39f69e77fa983b.tar.gz
gentoo-2-7117ac361ee79957f22dc467fe39f69e77fa983b.tar.bz2
gentoo-2-7117ac361ee79957f22dc467fe39f69e77fa983b.zip
Version bump. Shut up repoman warning.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x2324E7B566DF2611!)
Diffstat (limited to 'dev-libs/wayland')
-rw-r--r--dev-libs/wayland/ChangeLog10
-rw-r--r--dev-libs/wayland/wayland-1.3.0.ebuild6
-rw-r--r--dev-libs/wayland/wayland-1.6.1.ebuild57
3 files changed, 68 insertions, 5 deletions
diff --git a/dev-libs/wayland/ChangeLog b/dev-libs/wayland/ChangeLog
index 29a72613b3d7..6294cdcd88ad 100644
--- a/dev-libs/wayland/ChangeLog
+++ b/dev-libs/wayland/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/wayland
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/ChangeLog,v 1.48 2014/09/26 20:39:31 mattst88 Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/ChangeLog,v 1.49 2015/02/09 01:19:26 chithanh Exp $
+
+*wayland-1.6.1 (09 Feb 2015)
+
+ 09 Feb 2015; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +wayland-1.6.1.ebuild, wayland-1.3.0.ebuild:
+ Version bump. Shut up repoman warning.
*wayland-1.6.0 (26 Sep 2014)
diff --git a/dev-libs/wayland/wayland-1.3.0.ebuild b/dev-libs/wayland/wayland-1.3.0.ebuild
index a94f4180ad8c..ed262c0b7145 100644
--- a/dev-libs/wayland/wayland-1.3.0.ebuild
+++ b/dev-libs/wayland/wayland-1.3.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/wayland-1.3.0.ebuild,v 1.3 2014/06/18 19:18:47 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/wayland-1.3.0.ebuild,v 1.4 2015/02/09 01:19:26 chithanh Exp $
EAPI=5
@@ -36,7 +36,7 @@ DEPEND="${RDEPEND}
src_prepare() {
# Remove resources-test from TESTS as it has failed since it was added.
- sed -i -e 's/ resources-test$(EXEEXT)/ $(NULL)/' ${S}/tests/Makefile.in || die
+ sed -i -e 's/ resources-test$(EXEEXT)/ $(NULL)/' "${S}"/tests/Makefile.in || die
autotools-multilib_src_prepare
}
diff --git a/dev-libs/wayland/wayland-1.6.1.ebuild b/dev-libs/wayland/wayland-1.6.1.ebuild
new file mode 100644
index 000000000000..2cecf3e0ee99
--- /dev/null
+++ b/dev-libs/wayland/wayland-1.6.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/wayland-1.6.1.ebuild,v 1.1 2015/02/09 01:19:26 chithanh Exp $
+
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/${PN}/${PN}"
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ AUTOTOOLS_AUTORECONF=1
+fi
+
+inherit autotools-multilib toolchain-funcs $GIT_ECLASS
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="http://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc static-libs"
+
+RDEPEND=">=dev-libs/expat-2.1.0-r3:=[${MULTILIB_USEDEP}]
+ >=virtual/libffi-3.0.13-r1:=[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_enable doc documentation)
+ )
+ if tc-is-cross-compiler ; then
+ myeconfargs+=( --disable-scanner )
+ fi
+ if ! multilib_is_native_abi; then
+ myeconfargs+=( --disable-documentation )
+ fi
+
+ autotools-multilib_src_configure
+}
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ autotools-multilib_src_test
+}