summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2013-01-21 01:40:11 +0000
committerMatt Turner <mattst88@gentoo.org>2013-01-21 01:40:11 +0000
commit955eb0d3b5b149ceb3c7ce67249327c47ed7ca92 (patch)
treea1d8ddcc69aeda4c9d3b4d64ed5b39a351cea6cf /dev-libs/wayland
parentAdd s390 keywords #453114 by Sergey Popov. (diff)
downloadgentoo-2-955eb0d3b5b149ceb3c7ce67249327c47ed7ca92.tar.gz
gentoo-2-955eb0d3b5b149ceb3c7ce67249327c47ed7ca92.tar.bz2
gentoo-2-955eb0d3b5b149ceb3c7ce67249327c47ed7ca92.zip
Version bump to 1.0.3.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 974CA72A)
Diffstat (limited to 'dev-libs/wayland')
-rw-r--r--dev-libs/wayland/ChangeLog9
-rw-r--r--dev-libs/wayland/wayland-1.0.3.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/dev-libs/wayland/ChangeLog b/dev-libs/wayland/ChangeLog
index 59588aee762c..3e02b4f4ad27 100644
--- a/dev-libs/wayland/ChangeLog
+++ b/dev-libs/wayland/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/wayland
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/ChangeLog,v 1.8 2012/12/19 15:50:08 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/ChangeLog,v 1.9 2013/01/21 01:40:11 mattst88 Exp $
+
+*wayland-1.0.3 (21 Jan 2013)
+
+ 21 Jan 2013; Matt Turner <mattst88@gentoo.org> +wayland-1.0.3.ebuild:
+ Version bump to 1.0.3.
19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> wayland-0.95.0.ebuild:
Add ~ia64, wrt bug #403015
diff --git a/dev-libs/wayland/wayland-1.0.3.ebuild b/dev-libs/wayland/wayland-1.0.3.ebuild
new file mode 100644
index 000000000000..b59253a9587e
--- /dev/null
+++ b/dev-libs/wayland/wayland-1.0.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/wayland-1.0.3.ebuild,v 1.1 2013/01/21 01:40:11 mattst88 Exp $
+
+EAPI=4
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/${PN}/${PN}"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-2"
+ EXPERIMENTAL="true"
+fi
+
+inherit autotools toolchain-funcs $GIT_ECLASS
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="http://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
+fi
+
+LICENSE="CCPL-Attribution-ShareAlike-3.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="dev-libs/expat
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt"
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ if tc-is-cross-compiler ; then
+ econf $(use_enable static-libs static) --disable-scanner
+ else
+ econf $(use_enable static-libs static)
+ fi
+}