summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-12-05 18:36:55 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-12-05 18:36:55 +0000
commit901e47567e85b6f24712a17f77fb1e53a13a8c30 (patch)
tree2f0b9f723b814d05ab75cadc465f04fc01671684 /dev-libs/xapian
parentVersion bump =D (diff)
downloadgentoo-2-901e47567e85b6f24712a17f77fb1e53a13a8c30.tar.gz
gentoo-2-901e47567e85b6f24712a17f77fb1e53a13a8c30.tar.bz2
gentoo-2-901e47567e85b6f24712a17f77fb1e53a13a8c30.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-libs/xapian')
-rw-r--r--dev-libs/xapian/ChangeLog7
-rw-r--r--dev-libs/xapian/xapian-1.2.16.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-libs/xapian/ChangeLog b/dev-libs/xapian/ChangeLog
index 703d79fceab3..8e69c67c1b9d 100644
--- a/dev-libs/xapian/ChangeLog
+++ b/dev-libs/xapian/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/xapian
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v 1.111 2013/11/24 18:39:08 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v 1.112 2013/12/05 18:36:55 blueness Exp $
+
+*xapian-1.2.16 (05 Dec 2013)
+
+ 05 Dec 2013; Anthony G. Basile <blueness@gentoo.org> +xapian-1.2.16.ebuild:
+ Version bump
24 Nov 2013; Agostino Sarubbo <ago@gentoo.org> xapian-1.2.14.ebuild:
Stable for sparc, wrt bug #470402
diff --git a/dev-libs/xapian/xapian-1.2.16.ebuild b/dev-libs/xapian/xapian-1.2.16.ebuild
new file mode 100644
index 000000000000..be247a7890f8
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.2.16.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/xapian-1.2.16.ebuild,v 1.1 2013/12/05 18:36:55 blueness Exp $
+
+EAPI="5"
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc static-libs -sse +sse2 +brass +chert +inmemory"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local myconf=""
+
+ ewarn
+ if use sse2; then
+ ewarn "Using sse2"
+ myconf="${myconf} --enable-sse=sse2"
+ else
+ if use sse; then
+ ewarn "Using sse"
+ myconf="${myconf} --enable-sse=sse"
+ else
+ ewarn "Disabling sse and sse2"
+ myconf="${myconf} --disable-sse"
+ fi
+ fi
+ ewarn
+
+ myconf="${myconf} $(use_enable static-libs static)"
+
+ use brass || myconf="${myconf} --disable-backend-brass"
+ use chert || myconf="${myconf} --disable-backend-chert"
+ use inmemory || myconf="${myconf} --disable-backend-inmemory"
+
+ myconf="${myconf} --enable-backend-flint --enable-backend-remote"
+
+ econf $myconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ mv "${D}usr/share/doc/xapian-core" "${D}usr/share/doc/${PF}"
+ use doc || rm -rf "${D}usr/share/doc/${PF}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS
+}
+
+src_test() {
+ emake check VALGRIND=
+}