summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-23 22:31:59 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-23 22:31:59 +0000
commit7aee42a389ab764e9433f7688272e317c34d5d0f (patch)
tree0219ae1675cf34af4ea27b87aa24053be75b9be0 /dev-libs/yajl/files
parentFirst release candidate for openoffice-bin-3.2.1 (diff)
downloadgentoo-2-7aee42a389ab764e9433f7688272e317c34d5d0f.tar.gz
gentoo-2-7aee42a389ab764e9433f7688272e317c34d5d0f.tar.bz2
gentoo-2-7aee42a389ab764e9433f7688272e317c34d5d0f.zip
Initial import in main tree of yajl, needed for yajl-ruby which is in turn optionally used by the new Rails. Assigned to ruby herd for now. Thanks to the Sunrise people for the ebuild.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/yajl/files')
-rw-r--r--dev-libs/yajl/files/yajl-fix_cmakelists.patch23
-rw-r--r--dev-libs/yajl/files/yajl-fix_tests.patch15
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/yajl/files/yajl-fix_cmakelists.patch b/dev-libs/yajl/files/yajl-fix_cmakelists.patch
new file mode 100644
index 000000000000..95e794dfd84f
--- /dev/null
+++ b/dev-libs/yajl/files/yajl-fix_cmakelists.patch
@@ -0,0 +1,23 @@
+diff -urN lloyd-yajl-9c15d72//src/CMakeLists.txt lloyd-yajl-9c15d72.new//src/CMakeLists.txt
+--- lloyd-yajl-9c15d72//src/CMakeLists.txt 2010-01-08 18:05:11.000000000 +0100
++++ lloyd-yajl-9c15d72.new//src/CMakeLists.txt 2010-04-04 23:49:02.000000000 +0200
+@@ -42,7 +42,7 @@
+ ADD_DEFINITIONS(-DYAJL_BUILD)
+
+ # set up some paths
+-SET (libDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/lib)
++SET (libDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/lib${LIB_SUFFIX})
+ SET (incDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/include/yajl)
+
+ # set the output path for libraries
+@@ -77,8 +77,8 @@
+ INCLUDE_DIRECTORIES(${incDir}/..)
+
+ IF(NOT WIN32)
+- INSTALL(TARGETS yajl LIBRARY DESTINATION lib)
+- INSTALL(TARGETS yajl_s ARCHIVE DESTINATION lib)
++ INSTALL(TARGETS yajl LIBRARY DESTINATION lib${LIB_SUFFIX})
++ INSTALL(TARGETS yajl_s ARCHIVE DESTINATION lib${LIB_SUFFIX})
+ INSTALL(DIRECTORY api/ DESTINATION include/yajl
+ FILES_MATCHING PATTERN "*.h")
+ ENDIF()
diff --git a/dev-libs/yajl/files/yajl-fix_tests.patch b/dev-libs/yajl/files/yajl-fix_tests.patch
new file mode 100644
index 000000000000..b4a6498ced4c
--- /dev/null
+++ b/dev-libs/yajl/files/yajl-fix_tests.patch
@@ -0,0 +1,15 @@
+diff -urN lloyd-yajl-9c15d72.old/test/run_tests.sh lloyd-yajl-9c15d72//test/run_tests.sh
+--- lloyd-yajl-9c15d72.old/test/run_tests.sh 2010-04-04 23:59:51.000000000 +0200
++++ lloyd-yajl-9c15d72//test/run_tests.sh 2010-04-05 00:00:26.000000000 +0200
+@@ -8,9 +8,9 @@
+ # find test binary on both platforms. allow the caller to force a
+ # particular test binary (useful for non-cmake build systems).
+ if [ -z "$testBin" ]; then
+- testBin="../build/test/Debug/yajl_test.exe"
++ testBin="./yajl_test.exe"
+ if [[ ! -x $testBin ]] ; then
+- testBin="../build/test/yajl_test"
++ testBin="./yajl_test"
+ if [[ ! -x $testBin ]] ; then
+ echo "cannot execute test binary: '$testBin'"
+ exit 1;