summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDawid Węgliński <cla@gentoo.org>2010-01-17 23:03:32 +0000
committerDawid Węgliński <cla@gentoo.org>2010-01-17 23:03:32 +0000
commit1e1ae76b1d5f6efd059d84d925a88c5dd0560e70 (patch)
tree6654901842a1ff9a12b4fe593e6457c38ffd84d4 /dev-libs
parentStable for HPPA (bug #294958). (diff)
downloadgentoo-2-1e1ae76b1d5f6efd059d84d925a88c5dd0560e70.tar.gz
gentoo-2-1e1ae76b1d5f6efd059d84d925a88c5dd0560e70.tar.bz2
gentoo-2-1e1ae76b1d5f6efd059d84d925a88c5dd0560e70.zip
Version bump. Patches by Tim Harder (bug #301028).
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/cdk/ChangeLog10
-rw-r--r--dev-libs/cdk/cdk-5.0.20090215.ebuild49
-rw-r--r--dev-libs/cdk/files/cdk-5.0.20090215-ldflags.patch33
3 files changed, 90 insertions, 2 deletions
diff --git a/dev-libs/cdk/ChangeLog b/dev-libs/cdk/ChangeLog
index ef1b36961eab..6e603912919c 100644
--- a/dev-libs/cdk/ChangeLog
+++ b/dev-libs/cdk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/cdk
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cdk/ChangeLog,v 1.62 2009/12/15 19:08:03 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cdk/ChangeLog,v 1.63 2010/01/17 23:03:31 cla Exp $
+
+*cdk-5.0.20090215 (17 Jan 2010)
+
+ 17 Jan 2010; Dawid Węgliński <cla@gentoo.org> +cdk-5.0.20090215.ebuild,
+ +files/cdk-5.0.20090215-ldflags.patch:
+ Version bump. Patches by Tim Harder. (bug #301028)
15 Dec 2009; Raúl Porcel <armin76@gentoo.org> cdk-5.0.20081105.ebuild:
ia64/s390/sparc stable wrt #287511
diff --git a/dev-libs/cdk/cdk-5.0.20090215.ebuild b/dev-libs/cdk/cdk-5.0.20090215.ebuild
new file mode 100644
index 000000000000..84b8f31a6290
--- /dev/null
+++ b/dev-libs/cdk/cdk-5.0.20090215.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cdk/cdk-5.0.20090215.ebuild,v 1.1 2010/01/17 23:03:31 cla Exp $
+
+EAPI="2"
+
+inherit eutils versionator toolchain-funcs
+
+MY_P="${PN}-$(replace_version_separator 2 -)"
+DESCRIPTION="A library of curses widgets"
+HOMEPAGE="http://dickey.his.com/cdk/cdk.html"
+SRC_URI="ftp://invisible-island.net/cdk/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+DEPEND=">=sys-libs/ncurses-5.2"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_configure() {
+ econf --with-ncurses --with-libtool
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ DOCUMENT_DIR="${D}/usr/share/doc/${MY_P}" install \
+ || die "emake install failed"
+
+ if $(use examples); then
+ for x in include c++ demos examples cli cli/utils cli/samples; do
+ docinto $x
+ find $x -maxdepth 1 -mindepth 1 -type f -print0 | xargs -0 dodoc
+ done
+ fi
+}
diff --git a/dev-libs/cdk/files/cdk-5.0.20090215-ldflags.patch b/dev-libs/cdk/files/cdk-5.0.20090215-ldflags.patch
new file mode 100644
index 000000000000..e9ef00dfc477
--- /dev/null
+++ b/dev-libs/cdk/files/cdk-5.0.20090215-ldflags.patch
@@ -0,0 +1,33 @@
+--- cdk-5.0-20090215.orig/aclocal.m4 2009-06-16 00:38:32.945387085 -0700
++++ cdk-5.0-20090215/aclocal.m4 2009-06-16 00:40:01.310004647 -0700
+@@ -2425,7 +2425,7 @@
+ AC_MSG_ERROR(Cannot find libtool)
+ fi
+ ])dnl
+- LIB_CREATE='${LIBTOOL} --mode=link ${CC} -rpath ${DESTDIR}${libdir} -version-info `cut -f1 ${srcdir}/VERSION` ${LIBTOOL_OPTS} -o'
++ LIB_CREATE='${LIBTOOL} --mode=link ${CC} -rpath ${DESTDIR}${libdir} -version-info `cut -f1 ${srcdir}/VERSION` ${LDFLAGS} ${LIBTOOL_OPTS} -o'
+ LIB_OBJECT='${OBJECTS:.o=.lo}'
+ LIB_SUFFIX=.la
+ LIB_CLEAN='${LIBTOOL} --mode=clean'
+--- cdk-5.0-20090215.orig/configure 2009-06-16 00:38:32.964004839 -0700
++++ cdk-5.0-20090215/configure 2009-06-16 00:40:29.187005050 -0700
+@@ -3869,7 +3869,7 @@
+ echo "$as_me: error: Cannot find libtool" >&2;}
+ { (exit 1); exit 1; }; }
+ fi
+- LIB_CREATE='${LIBTOOL} --mode=link ${CC} -rpath ${DESTDIR}${libdir} -version-info `cut -f1 ${srcdir}/VERSION` ${LIBTOOL_OPTS} -o'
++ LIB_CREATE='${LIBTOOL} --mode=link ${CC} -rpath ${DESTDIR}${libdir} -version-info `cut -f1 ${srcdir}/VERSION` ${LDFLAGS} ${LIBTOOL_OPTS} -o'
+ LIB_OBJECT='${OBJECTS:.o=.lo}'
+ LIB_SUFFIX=.la
+ LIB_CLEAN='${LIBTOOL} --mode=clean'
+--- cdk-5.0-20090215.orig/Makefile.in 2009-06-16 00:38:32.951004532 -0700
++++ cdk-5.0-20090215/Makefile.in 2009-06-16 00:39:28.240044875 -0700
+@@ -267,7 +267,7 @@
+ all cdklib :: $(DEFAULT)
+
+ $(CDKLIB) :: $(OBJECTS)
+- @echo creating $@; $(LIBTOOL_CREATE) $@ $(LIB_OBJECT)
++ @echo creating $@; $(LIBTOOL_CREATE) $@ $(LIB_OBJECT) $(LIBS)
+ @$(RANLIB) $@
+
+ cdkshlib $(CDKSHLIB) :: $(CDKSHOBJS)