summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-09-29 09:55:43 +0000
committerPacho Ramos <pacho@gentoo.org>2012-09-29 09:55:43 +0000
commit229a952fc90dc36ca4529ad9787086977abd742d (patch)
treec62bb182a98a60310105a84ce8af3c4bf6f49d97 /dev-libs
parentVersion bump. (diff)
downloadgentoo-2-229a952fc90dc36ca4529ad9787086977abd742d.tar.gz
gentoo-2-229a952fc90dc36ca4529ad9787086977abd742d.tar.bz2
gentoo-2-229a952fc90dc36ca4529ad9787086977abd742d.zip
Version bump, drop old.
(Portage version: 2.1.11.19/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libsigc++/ChangeLog10
-rw-r--r--dev-libs/libsigc++/libsigc++-2.2.11.ebuild (renamed from dev-libs/libsigc++/libsigc++-2.2.9.ebuild)24
-rw-r--r--dev-libs/libsigc++/libsigc++-2.2.7.ebuild57
3 files changed, 17 insertions, 74 deletions
diff --git a/dev-libs/libsigc++/ChangeLog b/dev-libs/libsigc++/ChangeLog
index 6cdaa6900130..3a79ec309cd4 100644
--- a/dev-libs/libsigc++/ChangeLog
+++ b/dev-libs/libsigc++/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libsigc++
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/ChangeLog,v 1.174 2011/10/30 15:09:54 armin76 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/ChangeLog,v 1.175 2012/09/29 09:55:43 pacho Exp $
+
+*libsigc++-2.2.11 (29 Sep 2012)
+
+ 29 Sep 2012; Pacho Ramos <pacho@gentoo.org> +libsigc++-2.2.11.ebuild,
+ -libsigc++-2.2.7.ebuild, -libsigc++-2.2.9.ebuild:
+ Version bump, drop old.
30 Oct 2011; Raúl Porcel <armin76@gentoo.org> libsigc++-2.2.10.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #385699
diff --git a/dev-libs/libsigc++/libsigc++-2.2.9.ebuild b/dev-libs/libsigc++/libsigc++-2.2.11.ebuild
index 3bfdae70b7c9..63fb1efc1e49 100644
--- a/dev-libs/libsigc++/libsigc++-2.2.9.ebuild
+++ b/dev-libs/libsigc++/libsigc++-2.2.11.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-2.2.9.ebuild,v 1.7 2011/10/04 14:21:08 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-2.2.11.ebuild,v 1.1 2012/09/29 09:55:43 pacho Exp $
-EAPI="3"
+EAPI="4"
inherit base eutils gnome.org flag-o-matic
@@ -11,7 +11,7 @@ HOMEPAGE="http://libsigc.sourceforge.net/"
LICENSE="LGPL-2.1"
SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ~ppc ~ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="doc static-libs test"
DEPEND="sys-devel/m4"
@@ -38,19 +38,13 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die "make install failed."
- dodoc AUTHORS ChangeLog README NEWS TODO || die "dodoc failed"
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README NEWS TODO
+ use static-libs || find "${D}" -name '*.la' -exec rm -f {} +
if use doc ; then
- dohtml -r docs/reference/html/* docs/images/* || die "dohtml failed"
+ dohtml -r docs/reference/html/* docs/images/*
insinto /usr/share/doc/${PF}
- doins -r examples || die "doins failed"
+ doins -r examples
fi
}
-
-pkg_postinst() {
- ewarn "To allow parallel installation of sigc++-1.0, sigc++-1.2, and sigc++2.0"
- ewarn "the header files are now installed in a version specific"
- ewarn "subdirectory. Be sure to unmerge any libsigc++ versions"
- ewarn "< 1.0.4 that you may have previously installed."
-}
diff --git a/dev-libs/libsigc++/libsigc++-2.2.7.ebuild b/dev-libs/libsigc++/libsigc++-2.2.7.ebuild
deleted file mode 100644
index f39a7da38708..000000000000
--- a/dev-libs/libsigc++/libsigc++-2.2.7.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-2.2.7.ebuild,v 1.8 2011/08/26 01:59:16 mattst88 Exp $
-
-EAPI="3"
-
-inherit base eutils gnome.org flag-o-matic
-
-DESCRIPTION="Typesafe callback system for standard C++"
-HOMEPAGE="http://libsigc.sourceforge.net/"
-
-LICENSE="LGPL-2.1"
-SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-DEPEND="sys-devel/m4"
-RDEPEND=""
-
-# Needs mm-common for eautoreconf
-src_prepare() {
- # don't waste time building examples
- sed -i 's|^\(SUBDIRS =.*\)examples\(.*\)$|\1\2|' \
- Makefile.am Makefile.in || die "sed examples failed"
-
- # don't waste time building tests unless USE=test
- if ! use test ; then
- sed -i 's|^\(SUBDIRS =.*\)tests\(.*\)$|\1\2|' \
- Makefile.am Makefile.in || die "sed tests failed"
- fi
-}
-
-src_configure() {
- filter-flags -fno-exceptions
-
- local myconf="$myconf $(use_enable doc documentation)"
-
- econf ${myconf} || die "econf failed."
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed."
- dodoc AUTHORS ChangeLog README NEWS TODO || die "dodoc failed"
-
- if use doc ; then
- dohtml -r docs/reference/html/* docs/images/* || die "dohtml failed"
- insinto /usr/share/doc/${PF}
- doins -r examples || die "doins failed"
- fi
-}
-
-pkg_postinst() {
- ewarn "To allow parallel installation of sigc++-1.0, sigc++-1.2, and sigc++2.0"
- ewarn "the header files are now installed in a version specific"
- ewarn "subdirectory. Be sure to unmerge any libsigc++ versions"
- ewarn "< 1.0.4 that you may have previously installed."
-}