summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-12-18 09:10:53 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-12-18 09:10:53 +0000
commit27a88e6e0a13fb330a4128e96f5f5698c9ebce5c (patch)
tree9708da5bea075ae485d8dc11df5fe75c172d5683 /dev-libs
parentVersion bumped. (diff)
downloadgentoo-2-27a88e6e0a13fb330a4128e96f5f5698c9ebce5c.tar.gz
gentoo-2-27a88e6e0a13fb330a4128e96f5f5698c9ebce5c.tar.bz2
gentoo-2-27a88e6e0a13fb330a4128e96f5f5698c9ebce5c.zip
Include upstream patch to define generic symbols carefully wrt #347636 by Dennis Schridde.
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libffi/ChangeLog9
-rw-r--r--dev-libs/libffi/files/libffi-3.0.9-define-generic-symbols-carefully.patch69
-rw-r--r--dev-libs/libffi/libffi-3.0.9-r1.ebuild43
3 files changed, 120 insertions, 1 deletions
diff --git a/dev-libs/libffi/ChangeLog b/dev-libs/libffi/ChangeLog
index c4f88ba0cd8f..ea8c0b31d0ba 100644
--- a/dev-libs/libffi/ChangeLog
+++ b/dev-libs/libffi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libffi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/ChangeLog,v 1.107 2010/09/20 17:55:49 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/ChangeLog,v 1.108 2010/12/18 09:10:53 ssuominen Exp $
+
+*libffi-3.0.9-r1 (18 Dec 2010)
+
+ 18 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +libffi-3.0.9-r1.ebuild,
+ +files/libffi-3.0.9-define-generic-symbols-carefully.patch:
+ Include upstream patch to define generic symbols carefully wrt #347636 by
+ Dennis Schridde.
20 Sep 2010; Raúl Porcel <armin76@gentoo.org> libffi-3.0.9.ebuild,
+files/libffi-3.0.9-arm-oabi.patch:
diff --git a/dev-libs/libffi/files/libffi-3.0.9-define-generic-symbols-carefully.patch b/dev-libs/libffi/files/libffi-3.0.9-define-generic-symbols-carefully.patch
new file mode 100644
index 000000000000..1fd6aace4950
--- /dev/null
+++ b/dev-libs/libffi/files/libffi-3.0.9-define-generic-symbols-carefully.patch
@@ -0,0 +1,69 @@
+http://bugs.gentoo.org/347636
+
+Index: libffi/include/ffi.h.in
+===================================================================
+--- libffi.orig/include/ffi.h.in
++++ libffi/include/ffi.h.in
+@@ -57,7 +57,9 @@ extern "C" {
+ #endif
+
+ /* Specify which architecture libffi is configured for. */
++#ifndef @TARGET@
+ #define @TARGET@
++#endif
+
+ /* ---- System configuration information --------------------------------- */
+
+Index: libffi/src/powerpc/ffitarget.h
+===================================================================
+--- libffi.orig/src/powerpc/ffitarget.h
++++ libffi/src/powerpc/ffitarget.h
+@@ -31,12 +31,18 @@
+ /* ---- System specific configurations ----------------------------------- */
+
+ #if defined (POWERPC) && defined (__powerpc64__) /* linux64 */
++#ifndef POWERPC64
+ #define POWERPC64
++#endif
+ #elif defined (POWERPC_DARWIN) && defined (__ppc64__) /* Darwin */
++#ifndef POWERPC64
+ #define POWERPC64
++#endif
+ #elif defined (POWERPC_AIX) && defined (__64BIT__) /* AIX64 */
++#ifndef POWERPC64
+ #define POWERPC64
+ #endif
++#endif
+
+ #ifndef LIBFFI_ASM
+ typedef unsigned long ffi_arg;
+Index: libffi/src/s390/ffitarget.h
+===================================================================
+--- libffi.orig/src/s390/ffitarget.h
++++ libffi/src/s390/ffitarget.h
+@@ -28,8 +28,10 @@
+ #define LIBFFI_TARGET_H
+
+ #if defined (__s390x__)
++#ifndef S390X
+ #define S390X
+ #endif
++#endif
+
+ /* ---- System specific configurations ----------------------------------- */
+
+Index: libffi/src/sparc/ffitarget.h
+===================================================================
+--- libffi.orig/src/sparc/ffitarget.h
++++ libffi/src/sparc/ffitarget.h
+@@ -30,8 +30,10 @@
+ /* ---- System specific configurations ----------------------------------- */
+
+ #if defined(__arch64__) || defined(__sparcv9)
++#ifndef SPARC64
+ #define SPARC64
+ #endif
++#endif
+
+ #ifndef LIBFFI_ASM
+ typedef unsigned long ffi_arg;
diff --git a/dev-libs/libffi/libffi-3.0.9-r1.ebuild b/dev-libs/libffi/libffi-3.0.9-r1.ebuild
new file mode 100644
index 000000000000..e677e8c6d33a
--- /dev/null
+++ b/dev-libs/libffi/libffi-3.0.9-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/libffi-3.0.9-r1.ebuild,v 1.1 2010/12/18 09:10:53 ssuominen Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="a portable, high level programming interface to various calling conventions."
+HOMEPAGE="http://sourceware.org/libffi/"
+SRC_URI="ftp://sourceware.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug static-libs test"
+
+RDEPEND=""
+DEPEND="test? ( dev-util/dejagnu )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${P}-interix.patch \
+ "${FILESDIR}"/${P}-irix.patch \
+ "${FILESDIR}"/${P}-arm-oabi.patch \
+ "${FILESDIR}"/${P}-define-generic-symbols-carefully.patch
+
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable debug)
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog* README
+ find "${D}" -type f -name '*.la' -exec rm -f '{}' +
+}