summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-11-19 20:28:49 +0000
committerJeroen Roovers <jer@gentoo.org>2012-11-19 20:28:49 +0000
commit28cdb0bab8755421e72418c9e9902ddf75e9bd06 (patch)
tree45d25e9f24a6c28f7330e8636e984dcd73aa933e /dev-libs
parentUnrestrict python 3. (diff)
downloadgentoo-2-28cdb0bab8755421e72418c9e9902ddf75e9bd06.tar.gz
gentoo-2-28cdb0bab8755421e72418c9e9902ddf75e9bd06.tar.bz2
gentoo-2-28cdb0bab8755421e72418c9e9902ddf75e9bd06.zip
Version bump.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libevent/ChangeLog9
-rw-r--r--dev-libs/libevent/libevent-2.0.21.ebuild56
-rw-r--r--dev-libs/libevent/libevent-2.1.2.ebuild56
3 files changed, 120 insertions, 1 deletions
diff --git a/dev-libs/libevent/ChangeLog b/dev-libs/libevent/ChangeLog
index 95f0dc8e48cb..e6f99aa113e8 100644
--- a/dev-libs/libevent/ChangeLog
+++ b/dev-libs/libevent/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libevent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libevent/ChangeLog,v 1.243 2012/11/17 17:56:03 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libevent/ChangeLog,v 1.244 2012/11/19 20:28:49 jer Exp $
+
+*libevent-2.1.2 (19 Nov 2012)
+*libevent-2.0.21 (19 Nov 2012)
+
+ 19 Nov 2012; Jeroen Roovers <jer@gentoo.org> +libevent-2.0.21.ebuild,
+ +libevent-2.1.2.ebuild:
+ Version bump.
17 Nov 2012; Jeroen Roovers <jer@gentoo.org> -libevent-2.0.18.ebuild:
Old.
diff --git a/dev-libs/libevent/libevent-2.0.21.ebuild b/dev-libs/libevent/libevent-2.0.21.ebuild
new file mode 100644
index 000000000000..eff08d52aba9
--- /dev/null
+++ b/dev-libs/libevent/libevent-2.0.21.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libevent/libevent-2.0.21.ebuild,v 1.1 2012/11/19 20:28:49 jer Exp $
+
+EAPI="2"
+
+inherit eutils libtool
+
+MY_P="${P}-stable"
+
+DESCRIPTION="A library to execute a function when a specific event occurs on a file descriptor"
+HOMEPAGE="http://monkey.org/~provos/libevent/"
+SRC_URI="mirror://sourceforge/levent/files/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+ssl static-libs test"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+RDEPEND="
+ ${DEPEND}
+ !<=dev-libs/9libs-1.0
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ elibtoolize
+
+ # don't waste time building tests/samples
+ sed -i \
+ -e 's|^\(SUBDIRS =.*\)sample test\(.*\)$|\1\2|' \
+ Makefile.in || die "sed Makefile.in failed"
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable ssl openssl)
+}
+
+src_test() {
+ # The test suite doesn't quite work (see bug #406801 for the latest
+ # installment in a riveting series of reports).
+ :
+ # emake -C test check | tee "${T}"/tests
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README ChangeLog
+ if ! use static-libs; then
+ rm -f "${D}"/usr/lib*/libevent*.la
+ fi
+}
diff --git a/dev-libs/libevent/libevent-2.1.2.ebuild b/dev-libs/libevent/libevent-2.1.2.ebuild
new file mode 100644
index 000000000000..c56362a7c270
--- /dev/null
+++ b/dev-libs/libevent/libevent-2.1.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libevent/libevent-2.1.2.ebuild,v 1.1 2012/11/19 20:28:49 jer Exp $
+
+EAPI=4
+inherit eutils libtool
+
+MY_P="${P}-alpha"
+
+DESCRIPTION="A library to execute a function when a specific event occurs on a file descriptor"
+HOMEPAGE="http://monkey.org/~provos/libevent/"
+SRC_URI="mirror://sourceforge/levent/files/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+ssl static-libs test"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+RDEPEND="
+ ${DEPEND}
+ !<=dev-libs/9libs-1.0
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ elibtoolize
+
+ # don't waste time building tests/samples
+ sed -i \
+ -e 's|^\(SUBDIRS =.*\)sample test\(.*\)$|\1\2|' \
+ Makefile.in || die "sed Makefile.in failed"
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable ssl openssl)
+}
+
+src_test() {
+ # The test suite doesn't quite work (see bug #406801 for the latest
+ # installment in a riveting series of reports).
+ :
+ # emake -C test check | tee "${T}"/tests
+}
+
+DOCS="README ChangeLog*"
+
+src_install() {
+ default
+ if ! use static-libs; then
+ rm -f "${D}"/usr/lib*/libevent*.la
+ fi
+}